[kea-dev] Build issues using master HEAD (cont' from: Server hangs at startup - issue with lock file)

Chaigneau, Nicolas nicolas.chaigneau at capgemini.com
Tue Dec 30 10:37:13 UTC 2014


Hello,


I've finally solved the issue with autoconf when trying to build Kea master HEAD from GitHub.


I first blamed the tools installed on my system, so I upgraded to the following versions:
- m4: 1.4.17 (from 1.14.13)
- autoconf: 2.69 (from 2.63)
- automake: 1.14 (from 1.11.1)
But in the end I think this was completely unnecessary. (I'm not reverting back to check, though.)



Actually there are two issues.


First:
Don't try to do this over NFS, it may not work (for me it doesn't). Better build Kea on a local FS, at least for non-tarball versions.
(as a side note, autoconf also refuses to build itself over NFS.)



Second:

	dos2unix configure.ac

(I'm not sure why it works for some people and not for me. Probably depends on the system...)



After fixing configure.ac, autoconf works fine:

	autoreconf --install



But now I'm stuck with another issue...
The configure worked, but "make" does not. I get the following errors:


	Making all in tests
	make[5]: Entering directory `/usr/kea/src/lib/log/tests'
	  GEN      s-messages
	'@@_NAMESPACE_INVALID_ARG,  @@Missing placeholder %1 for '23'@@ @@Missing placeholder %2 for 'isc::log
	make[5]: *** [s-messages] Error 1
	make[5]: Leaving directory `/usr/kea/src/lib/log/tests'
	make[4]: *** [all-recursive] Error 1
	make[4]: Leaving directory `/usr/kea/src/lib/log'
	make[3]: *** [all-recursive] Error 1
	make[3]: Leaving directory `/usr/kea/src/lib'
	make[2]: *** [all-recursive] Error 1
	make[2]: Leaving directory `/usr/kea/src'
	make[1]: *** [all-recursive] Error 1
	make[1]: Leaving directory `/usr/kea'
	make: *** [all] Error 2



Any idea on how to fix this ?



Regards,
Nicolas.

 
> 
> -----Message d'origine-----
> De : kea-dev-bounces at lists.isc.org [mailto:kea-dev-bounces at lists.isc.org] De la part de Chaigneau, Nicolas
> Envoyé : mercredi 17 septembre 2014 09:05
> À : Jeremy C. Reed
> Cc : kea-dev at lists.isc.org
> Objet : RE: Server hangs at startup - issue with lock file
> 
> 
> 
> The first command (aclocal) hangs.
> 
> I've tried to run it with strace; I noticed the following (I don't know if it's a problem or not):
> 
> stat("acinclude.m4", 0x20dd130)         = -1 ENOENT (No such file or directory)
> 
> And just before it hangs, the following errors:
> 
> ioctl(3, SNDCTL_TMR_TIMEBASE or TCGETS, 0x7fffd6159ce0) = -1 EINVAL (Invalid argument)
> lseek(3, 0, SEEK_CUR)                   = -1 ESPIPE (Illegal seek)
> fcntl(3, F_SETFD, FD_CLOEXEC)           = 0
> 
> 
> 
> 
> > On Tue, 16 Sep 2014, Chaigneau, Nicolas wrote:
> > 
> > > Here is the output of "autoreconf -vv --install" (until it hangs):
> > 
> > Thanks.
> > 
> > ...
> > > : command not found
> > > : command not found
> > 
> > I still don't see in there what was missing. Maybe you can run the parts step by step to see if can identify where problem is:
> > 
> > aclocal
> > libtoolize --copy # or glibtoolize
> > autoheader
> > automake --add-missing --copy
> > autoconf
> >
This message contains information that may be privileged or confidential and is the property of the Capgemini Group. It is intended only for the person to whom it is addressed. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.



More information about the kea-dev mailing list