[kea-dev] [Kea-users] kea-dhcp6 ignoring DHCPv6 messages received on a tuntap interface

Templin, Fred L Fred.L.Templin at boeing.com
Thu Apr 21 22:20:49 UTC 2016


Apologies; I included the wrong kea.conf file. Please use the one attached to this
message instead.

Thanks - Fred

> -----Original Message-----
> From: kea-users-bounces at lists.isc.org [mailto:kea-users-bounces at lists.isc.org] On Behalf Of Templin, Fred L
> Sent: Thursday, April 21, 2016 3:19 PM
> To: kea-users at lists.isc.org; kea-dev at lists.isc.org
> Cc: Benson, Michael W <michael.w.benson at boeing.com>
> Subject: [Kea-users] kea-dhcp6 ignoring DHCPv6 messages received on a tuntap interface
> 
> Hello,
> 
> We are using kea-dhcp6 version 1.0.0 over a tuntap interface in tun mode. We
> are sending DHCPv6 Solicit messages from a client to the kea server that is
> supposed to be listening on tun0 (see attached kea.conf). When we run
> "tcpdump -lnnXi tun0" on the kea server, we see what appear to be good
> DHCPv6 Solicits wrapped in relay-fwd wrappers. The client is sending the
> Solicits once per second, but the kea server never gives any indication that
> it has received any of the messages even when run in debug mode.
> 
> Here is what the relay-fwd wrapped DHCPv6 Solicit message looks like taken
> from tcpdump on the kea server's tun0 interface:
> 
> 14:59:37.334546 IP6 fe80::ffff:ffff:ffff:ffff.546 > ff02::1:2.547: dhcp6 relay-fwd
> 	0x0000:  6000 0000 008e 11ff fe80 0000 0000 0000  `...............
> 	0x0010:  ffff ffff ffff ffff ff02 0000 0000 0000  ................
> 	0x0020:  0000 0000 0001 0002 0222 0223 008e c44e  .........".#...N
> 	0x0030:  0c00 0000 0000 0000 0000 0000 0000 0000  ................
> 	0x0040:  0000 fe80 0000 0000 0000 ffff ffff ffff  ................
> 	0x0050:  ffff 0012 0004 0000 b0e2 0042 0020 0011  ...........B....
> 	0x0060:  001c 0000 b0e2 0001 0014 00ff aa04 0000  ................
> 	0x0070:  0000 0000 0000 0000 ffff 0000 0000 0009  ................
> 	0x0080:  0034 0185 2f37 0001 000a 0002 0000 b0e2  .4../7..........
> 	0x0090:  0000 0000 0006 0004 0017 0018 0008 0002  ................
> 	0x00a0:  0000 0019 000c 0000 b0e2 0000 0000 0000  ................
> 	0x00b0:  0000 000e 0000                           ......
> 
> and, here is the result of "ifconfig tun0" on the kea server:
> 
> tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
>           inet addr:10.8.0.1  P-t-P:10.8.0.1  Mask:255.255.255.0
>           inet6 addr: fe80::2/64 Scope:Link
>           UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
>           RX packets:746 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:100
>           RX bytes:135370 (135.3 KB)  TX bytes:912 (912.0 B)
> 
> Note that we have successfully used kea-dhcp6 over tuntap interfaces in
> tun mode in other application contexts. Could it be that there is some kind
> of tuntap configuration difference that is causing kea to ignore our messages?
> 
> Any ideas on how to debug this?
> 
> Thanks - Fred
> fred.l.templin at boeing.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kea.conf
Type: application/octet-stream
Size: 3804 bytes
Desc: kea.conf
URL: <https://lists.isc.org/pipermail/kea-dev/attachments/20160421/1daadc8d/attachment.obj>


More information about the kea-dev mailing list