[Kea-users] lease reading error

Todd Simmons (todsimmo) todsimmo at cisco.com
Tue Oct 25 20:59:46 UTC 2016


I had the same issue after the vm server was shutdown improperly after a power outage. I opened the file in VI and deleted all the leases (after saving a copy of course) and then it worked just fine. 

It's possible the file is damaged and that's causing the problem. 

Sent from my iPhone

> On Oct 25, 2016, at 3:44 PM, Munroe Sollog <mus3 at lehigh.edu> wrote:
> 
> running 1.0.0 code.  I stopped the service a while and then when I went to start it I got the
> following error:
> 
> kea-dhcp4[14193]: 2016-10-25 16:35:28.129 ERROR [kea-dhcp4.dhcp4/14193] DHCP4_INIT_FAIL failed to
> initialize Kea server: configuration error using file '/etc/kea/kea-dhcp4.conf': exceeded maximum
> number of failures 100 to read a lease from the lease file /var/lib/kea/kea-leases4.csv
> 
> 
> # kea-dhcp4 -V
> 1.0.0
> tarball
> linked with:
> log4plus 1.0.4
> OpenSSL 1.0.1t  3 May 2016
> database:
> MySQL backend 3.0, library 5.5.52
> PostgreSQL backend 2.0, library 90409
> Memfile backend 2.0
> 
> 
> 
> A quick google search yeilded the comments from the header file that causes the error output, but I
> don't understand why it can't read its lease file all of a sudden.  I don't know if it is pertinent,
> but there *a lot* of leases in the lease file:
> 
> # wc -l /var/lib/kea/kea-leases4.csv
> 4485457 /var/lib/kea/kea-leases4.csv
> 
> I obviously don't have 4.4million users though.
> 
> -- 
> Munroe Sollog
> LTS - Senior Network Engineer
> x85002
> _______________________________________________
> Kea-users mailing list
> Kea-users at lists.isc.org
> https://lists.isc.org/mailman/listinfo/kea-users


More information about the Kea-users mailing list