[Kea-users] Kea DHCPv6 not working for a relayed subnet, but fine for local subnet

Joelson Vendramin jtvendramin at yahoo.com.br
Mon Oct 22 18:13:07 UTC 2018


Hello,
I think that in case of relay, you need to specify the global IPv6 address in DHCPv6 configuration, like this:
        "interfaces": [ "em1", "em1/2001:db8::1" ]See this documentation:https://kea.isc.org/docs/kea-guide.html#dhcp6-unicast

Regards,
--Joelson Vendramin

      De: "chris at slater-walker.net" <chris at slater-walker.net>
 Para: kea-users at lists.isc.org 
 Enviadas: Segunda-feira, 22 de Outubro de 2018 14:45
 Assunto: [Kea-users] Kea DHCPv6 not working for a relayed subnet, but fine for local subnet
   
<!--#yiv1279239647 _filtered #yiv1279239647 {font-family:"Cambria Math";panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv1279239647 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}#yiv1279239647 #yiv1279239647 p.yiv1279239647MsoNormal, #yiv1279239647 li.yiv1279239647MsoNormal, #yiv1279239647 div.yiv1279239647MsoNormal {margin:0cm;margin-bottom:.0001pt;font-size:11.0pt;font-family:"Calibri", sans-serif;}#yiv1279239647 a:link, #yiv1279239647 span.yiv1279239647MsoHyperlink {color:#0563C1;text-decoration:underline;}#yiv1279239647 a:visited, #yiv1279239647 span.yiv1279239647MsoHyperlinkFollowed {color:#954F72;text-decoration:underline;}#yiv1279239647 span.yiv1279239647EmailStyle17 {font-family:"Calibri", sans-serif;}#yiv1279239647 .yiv1279239647MsoChpDefault {font-family:"Calibri", sans-serif;} _filtered #yiv1279239647 {margin:72.0pt 72.0pt 72.0pt 72.0pt;}#yiv1279239647 div.yiv1279239647WordSection1 {}-->Hi all  This has stumped me.  I’m using Kea 1.1.0 on Ubuntu 18.04 for IPv6 only. The v4 server is not installed.  It is serving addresses for the local subnet with no problem. I have a guest wireless network connected to an interface on my Cisco 1941 router. This router has a dhcpv6 relay destination of my Kea server.  Tcpdump on the server shows that the server is receiving relayed DHCP requests from clients on the guest network, and the packets contain a link address which is valid in the subnet definition in the Kea config; however the server is not responding in any fashion to these requests. It’s as if they were not there at all.  I have tried the “relay” IPv6 address option in the relevant subnet definition, even though it shouldn’t be necessary, but it makes no difference.  I’m sure this worked for a while but now I just can’t make it work.  Here is my config:  {  "Dhcp6":  {    "interfaces-config":    {      "interfaces": [ "em1" ]    },    "lease-database":    {      "type": "memfile",      "persist": true,      "name": "/var/kea/dhcp6.leases"    },    "expired-leases-processing":    {      "reclaim-timer-wait-time": 10,      "flush-reclaimed-timer-wait-time": 25,      "hold-reclaimed-time": 3600,      "max-reclaim-leases": 100,      "max-reclaim-time": 250,      "unwarned-reclaim-cycles": 5    },    "preferred-lifetime": 3000,    "valid-lifetime": 4000,    "renew-timer": 1000,    "rebind-timer": 2000,    "subnet6":    [      {        "subnet": "2xxx:8010:631f:2::/64",        "interface": "em1",        "id": 2,        "option-data":        [          {            "name": "dns-servers",            "data": "2xxx:8010:631f:2::fd"          },          {            "name": "domain-search",            "data": "my-domain.net"          }        ],        "pools": [ { "pool": "2xxx:8010:631f:2::101-2xxx:8010:631f:2::1ff" } ],        "reservations":        [          {            "duid": "00:01:00:01:1e:b7:90:35:f0:de:f1:00:93:b9",            "ip-addresses": [ "2xxx:8010:631f:2::b" ],            "hostname": "xxx-laptop1"          },          {            "duid": "00:01:00:01:20:54:28:1d:00:24:d7:68:ff:bc",            "ip-addresses": [ "2xxx:8010:631f:2::4" ],            "hostname": "xxx-laptop2"          },          {            "duid": "00:01:00:01:19:d5:b0:63:10:0b:a9:e5:72:04",            "ip-addresses": [ "2xxx:8010:631f:2::7" ],            "hostname": "yyy-laptop2"          },          {            "duid": "00:01:00:01:20:bd:bc:af:40:8d:5c:17:95:31",            "ip-addresses": [ "2xxx:8010:631f:2::13" ],            "hostname": "xxx-desktop"          },          {            "duid": "00:01:00:01:22:2D:F9:D5:D4:25:8B:11:73:99",            "ip-addresses": [ "2xxx:8010:631f:2::17" ],            "hostname": "yyy-laptop3"          },          {            "duid": "00:03:00:01:b4:b5:2f:0b:1c:cf",            "ip-addresses": [ "2xxx:8010:631f:2::fe" ],            "hostname": "printer"          }        ]      },      {        "subnet": "2xxx:8010:631f:64::/64",        "id": 100,        "option-data":        [          {            "name": "dns-servers",            "data": "2606:4700:4700::1111, 2606:4700:4700::1001"          }        ],        "pools": [ { "pool": "2xxx:8010:631f:64::101-2xxx:8010:631f:64::1ff" } ]      }    ]  },  "Logging":  {    "loggers":    [      {        "name": "kea-dhcp6",        "output_options":        [          {            "output": "/var/log/kea-dhcp6.log"          }        ],        "severity": "DEBUG",        "debuglevel": 3      }    ]  }}_______________________________________________
Kea-users mailing list
Kea-users at lists.isc.org
https://lists.isc.org/mailman/listinfo/kea-users


   
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20181022/59c1392f/attachment-0001.html>


More information about the Kea-users mailing list