[Kea-users] Kea DHCPv4 1.4.0-P1 HA snchro error

Ivan Stenda jaivast at gmail.com
Thu Oct 25 08:22:00 UTC 2018


some lease updates are not working correctly, generating this log message:
2018-10-24 10:53:24.541 WARN  [kea-dhcp4.ha-hooks/20371]
HA_LEASE_UPDATE_FAILED [hwtype=1 34:08:04:ac:53:22],
cid=[01:34:08:04:ac:53:22], tid=0xa915: lease update to server101 (
http://10.58.0.101:8080/) failed: body of the response must be a list

and this is view to failover communication for bad and correct updates:

POST / HTTP/1.1
Content-Length: 328
Content-Type: application/json
{ "arguments": { "client-id": "01:34:08:04:ac:53:22", "expire": 1540371418,
"force-create": true, "fqdn-fwd": true, "fqdn-rev": true, "hostname":
"D-Link\u0000", "hw-address": "34:08:04:ac:53:22", "ip-address":
"10.187.15.132", "state": 0, "subnet-id": 2, "valid-lft": 120 }, "command":
"lease4-update", "service": [ "dhcp4" ] }

HTTP/1.1 400 Bad Request
Content-Length: 40
Content-Type: application/json
Date: Wed, 24 Oct 2018 08:54:58 GMT
{ "result": 400, "text": "Bad Request" }

POST / HTTP/1.1
Content-Length: 318
Content-Type: application/json
{ "arguments": { "client-id": "01:48:62:76:92:02:ab", "expire": 1540371440,
"force-create": true, "fqdn-fwd": false, "fqdn-rev": false, "hostname": "",
"hw-address": "48:62:76:92:02:ab", "ip-address": "10.187.15.136", "state":
0, "subnet-id": 2, "valid-lft": 120 }, "command": "lease4-update",
"service": [ "dhcp4" ] }

HTTP/1.1 200 OK
Content-Length: 50
Content-Type: application/json
Date: Wed, 24 Oct 2018 08:55:20 GMT
[ { "result": 0, "text": "IPv4 lease updated." } ]


how can I report this issue ?

regards
i



>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20181025/bed26e54/attachment.html>


More information about the Kea-users mailing list