[Kea-users] DHCP4_CONFIG_LOAD_FAIL - "getNextRow failed" with MySQL

Fernando Ruza Rodriguez fernandor at sescam.jccm.es
Tue Jul 9 13:10:46 UTC 2019


The same it happened to me today. Delete records with leases < 0 solved
the problem.

One question, Who updates this table? a kea-dhcp proccess, a trigger?.
When is it updated?. In my case, it doesn't show the real and updated
information.

Thanks for any help. Regards,

Fernando.


-----Mensaje original-----
De: flingo <martin.messmer at t-systems.com>
Para: kea-users at lists.isc.org
Asunto: Re: [Kea-users] DHCP4_CONFIG_LOAD_FAIL - "getNextRow failed"
with MySQL
Fecha: Mon, 1 Jul 2019 13:14:28 -0700 (MST)


Exactly the same here: the Kea DHCP server setup worked for weeks and all
over sudden, after a configuration change / restart the servers refused to
start with the mentioned error. 

DELETE FROM lease4_stat where leases < 0 

solved the issue so far. Since I don't want to wait for the next occurence
of quite unfrequent issue, I changed the table description of lease4_stat,
so that field 'leases' is now 'BIGINT(20) UNSIGNED NULL DEFAULT NULL'. This
should prevent any further negative values. Hope this doesn't break the code
elsewhere. Let's wait and see ...

Here is my setup:
- 2 CentOS7 machines 
- each running KEA DHCP 1.5.0 and 
- MYSQL 5.7.x Leases Database 
- MYSQL Master-Master-Replication
- KEA HA / Failover (not load balancing) w/ send-lease-updates and
sync-leases set to false (i.e. leases are replicated via MySQL replication)




--
Sent from: http://kea-users.7364.n8.nabble.com/
_______________________________________________
Kea-users mailing list
Kea-users at lists.isc.org
https://lists.isc.org/mailman/listinfo/kea-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20190709/4b031793/attachment.html>


More information about the Kea-users mailing list