[Kea-users] Compilation of ISC DHCP code

Mayank Tiwari mike.tiwari at gmail.com
Wed Jun 19 22:03:36 UTC 2019


Hi,

  I am trying to compile ISC DHCP code as I want to use relay feature from
it. When I compile the code from
ftp://ftp.isc.org/isc/dhcp/4.4.1/dhcp-4.4.1.tar.gz link it works fine.

  However, when I try to checkout the code from git and compile it fails. I
check out the code from https://github.com/isc-projects/dhcp/tree/v4_4_1

  Steps used for compilation:
autoreconf -f -i
./configure
make
make install

  The requirement is make code compilable from the code checked out of git.

  The failure happens in configure step and the error is:
"configure: error: Where to find or build bind includes and libraries must
be specified'

  When I compared the code and the compilation steps between working and
non-working code I have observed that the bind folder is missing when I
checkout the code from git. However, the code downloaded from ftp server
has that folder.

$ ls -lrt bind/ --> Code from ftp folder
total 9576
-rw-rw-r-- 1 mayank mayank    4702 May 29 10:29 Makefile.in
-rw-rw-r-- 1 mayank mayank     183 May 29 10:29 version.tmp
-rw-rw-r-- 1 mayank mayank 9793066 May 29 10:29 bind.tar.gz

 My query. What are different steps for compilation from the code checked
out from git so that this bind related error does not come. Please provide
any inputs or reference. Or is there any other way to integrate bind
related code with the code checked out from git to make compilation work.

  I am doing the compilation inside the alpine docker container. Here is
the spec for it.

FROM alpine:3.8
RUN apk update && apk upgrade && apk add curl tar make gcc build-base wget
gnupg && \
    apk add tcpdump libtool autoconf automake alpine-sdk libcap-dev
openssl-dev --no-update && \
    apk add --no-cache bash libgcc git openssh


RUN mkdir /isc
RUN git clone --branch=v4_4_1 https://github.com/isc-projects/dhcp.git /isc
WORKDIR /isc



RUN autoreconf -f -i && \
    ./configure  && \
    make && \
    make install

  Please let me know if there is any alpine package which I need to install
to make it work so that the bind related error does not come. The same spec
works fine for the code checked out from ftp server which has bind folder.

Thanks and Regards,
Mayank
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20190619/5c491a67/attachment.html>


More information about the Kea-users mailing list