[Kea-users] Experimental binary Kea1.6 packages posted

Jason Guy jguy at cumulusnetworks.com
Mon Jun 24 15:25:36 UTC 2019


Hey Kevin.

It should be easy enough to test with the newer version of libboost-system
in buster. If it works fine, we can change the dependency to be
libboost-system (<= 1.67).

Hope it is that easy.
Jason


On Sun, Jun 23, 2019 at 9:44 AM Kevin Olbrich <ko at sv01.de> wrote:

> Hello Jason,
>
> sorry, it's not working:
>
> root at buildsrv01:~# apt-get install isc-kea-admin isc-kea-ctrl-agent
> isc-kea-dhcp4-server isc-kea-dhcp6-server isc-kea-dhcp-ddns-server
> python3-isc-kea-connector
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  isc-kea-admin : Depends: isc-kea-common (=
> 1.6.0-isc0025120190619100955) but it is not going to be installed
>                  Depends: libboost-system1.62.0 but it is not installable
>  isc-kea-ctrl-agent : Depends: isc-kea-common (=
> 1.6.0-isc0025120190619100955) but it is not going to be installed
>                       Depends: libboost-system1.62.0 but it is not
> installable
>  isc-kea-dhcp-ddns-server : Depends: isc-kea-common (=
> 1.6.0-isc0025120190619100955) but it is not going to be installed
>                             Depends: libboost-system1.62.0 but it is
> not installable
>  isc-kea-dhcp4-server : Depends: isc-kea-common (=
> 1.6.0-isc0025120190619100955) but it is not going to be installed
>                         Depends: libboost-system1.62.0 but it is not
> installable
>  isc-kea-dhcp6-server : Depends: isc-kea-common (=
> 1.6.0-isc0025120190619100955) but it is not going to be installed
>                         Depends: libboost-system1.62.0 but it is not
> installable
> E: Unable to correct problems, you have held broken packages.
>
> Theres only:
> https://packages.debian.org/buster/libboost-system1.67.0
>
> That's the same problem as before, when I tried to mix buster with Sury's
> repo.
>
> Kind regards
> Kevin
>
> Am Sa., 22. Juni 2019 um 14:43 Uhr schrieb Jason Guy <
> jguy at cumulusnetworks.com>:
> >
> > As far as I know, the same package should work with Buster, but I have
> not tried it yet.
> >
> > Jason
> >
> > On Fri, Jun 21, 2019 at 6:32 PM Kevin Olbrich <ko at sv01.de> wrote:
> >>
> >> Hello Victoria,
> >>
> >> is it possible to also build buster? I am in the position to test
> >> 1.6.0 but only with buster, not stable / stretch.
> >> Buster is around the corner and there is no compatible version of Kea
> yet.
> >>
> >> I did a quick test with cloudsmith and it's missing buster.
> >>
> >> Kind regards
> >> Kevin
> >>
> >> Am Fr., 21. Juni 2019 um 22:33 Uhr schrieb Victoria Risk <vicky at isc.org
> >:
> >> >
> >> > Kea-users,
> >> >
> >> > We have just set up a repository with brand-new binary packages for
> the Kea 1.6 beta using a hosted repository service.
> >> > The repository is at https://cloudsmith.io/~isc/repos/kea-1-6/
> >> >
> >> > Packages are available from ISC for:
> >> > CentOS7
> >> > Fedora 28 & 29
> >> > Debian 9
> >> > Ubuntu 18.10 & 19.04
> >> >
> >> > You should be able to install packages from there without any account
> or login. If you go to the site, and click on the link ’Set Me Up’ you will
> find explicit scripts for updating for each of those OSes listed above.
> >> >
> >> > Everything in this post is beta - the software is a beta version, we
> are testing the repo, and the packages are experimental.
> >> > Please give it a try and let us know what your experience is. We
> cannot guarantee that we won’t change anything - this is why we are asking
> for feedback.  If any part of the experience is dissappointing or confusing
> or not what what you expect, I would like to hear about it.  If you like
> it, it wouldn’t hurt to hear that too.
> >> >
> >> > We are planning to maintain this repo and these packages going
> forward for new Kea releases, if all goes well.
> >> >
> >> > ISC Support customers: we are setting up a restricted-access
> repository for the premium subscriber hooks. You should look for an update
> in your ticket queue next week with instructions on how to access that
> repository for the non-open source components.
> >> >
> >> > Regards,
> >> >
> >> > Vicky
> >> > -------
> >> >
> >> > Victoria Risk
> >> > Product Manager
> >> > Internet Systems Consortium
> >> > vicky at isc.org
> >> >
> >> >
> >> >
> >> >
> >> >
> >> > _______________________________________________
> >> > Kea-users mailing list
> >> > Kea-users at lists.isc.org
> >> > https://lists.isc.org/mailman/listinfo/kea-users
> >> _______________________________________________
> >> Kea-users mailing list
> >> Kea-users at lists.isc.org
> >> https://lists.isc.org/mailman/listinfo/kea-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20190624/ac70a54b/attachment.html>


More information about the Kea-users mailing list