[Kea-users] Use perfdhcp to test IoT DHCP server?

Rick Graham rickhg12hs at gmail.com
Tue May 7 11:55:00 UTC 2019


I'll investigate shutting down dnsmasq.  Currently, I believe dnsmasq is
being used by VMs on the host.

Thanks!

On Tue, May 7, 2019 at 1:46 PM Marcin Siodelski <marcin at isc.org> wrote:

> Right, and such conflict is a usual side effect of making perfdhcp
> simulate relayed traffic. The relay operates on port 67 (rather than
> 68), so it may be in conflict with running DHCP services on the given
> machine. I can only suggest shutting down dnsmasq if possible.
>
> Marcin
>
> On 07/05/2019 13:37, Rick Graham wrote:
> > Looks like dnsmasq is running on the same host where perfdhcp was
> > launched. I'm not sure how/if I can change this at the moment.
> >
> > On Tue, May 7, 2019 at 1:23 PM Marcin Siodelski <marcin at isc.org
> > <mailto:marcin at isc.org>> wrote:
> >
> >     This seems to indicate that there is some other process bound to the
> >     address of 10.20.100.12, port 67 on that machine. Most likely a DHCP
> >     server. Are you running your DHCP server under test on the same
> machine
> >     as perfdhcp?
> >
> >     Marcin
> >
> >     On 07/05/2019 13:14, Rick Graham wrote:
> >     > Still no luck.  :-(
> >     >
> >     > $ sudo perfdhcp -xaeistT -r1 -n1 -i -l wlp8s0 10.20.100.10
> >     > Running: perfdhcp -x aeistT -r 1 -n 1 -i -l wlp8s0 10.20.100.10
> >     > IPv4
> >     > DISCOVER-OFFER only
> >     > lease-type=address-only (IA_NA option added to the client's
> request)
> >     > rate[1/s]=1
> >     > num-request[0]=1
> >     > drop-time[0]=1
> >     > drop-time[1]=1
> >     > aggressivity=1
> >     > elp-offset=-1
> >     > sid-offset=-1
> >     > rip-offset=-1
> >     > diagnostic-selectors=aeistT
> >     > interface=wlp8s0
> >     > server=10.20.100.10
> >     > Set MAC to 00::0c::01::02::03::04
> >     > Set DUID to 0001000124642485000c01020304
> >     > Error running perfdhcp: Failed to bind socket 3 to
> >     10.20.100.12/port=67 <http://10.20.100.12/port=67>
> >     > <http://10.20.100.12/port=67>
> >     >
> >     >
> >     > On Tue, May 7, 2019 at 12:44 PM Thomas Markwalder <tmark at isc.org
> >     <mailto:tmark at isc.org>
> >     > <mailto:tmark at isc.org <mailto:tmark at isc.org>>> wrote:
> >     >
> >     >     Try dropping the "-L 6767".
> >     >
> >     >     Cheers,
> >     >
> >     >     Thomas
> >     >
> >
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20190507/c85ef0ab/attachment.html>


More information about the Kea-users mailing list