[Kea-users] KEA DHCP and VLANS...

Talkabout talk.about at gmx.de
Sat Feb 1 16:57:45 UTC 2020


Hi Tom,

thanks for your answer but both suggestions are difficult to accomplish. The first one is disqualified because other components in my Network infrastructure do not support vlan Tagging, the second one because my switch does not provide a dhcp relay Option.

I am wondering why KEA DHCP is not supporting such a configuration. Currently I am using dnsmasq and there I have no issues. Theoretically only a check is missing whether a particular packet is tagged, if so, do not consider the physical device for dhcp…

Can I assume that such an infrastructure will never be supported by KEA DHCP Server? If so this is really bad luck, I like the functionalities of this Software…

Thanks!

Bye

Gesendet von Mail für Windows 10

Von: Dajka Tamás
Gesendet: Samstag, 1. Februar 2020 17:43
An: 'Talkabout'; kea-users at lists.isc.org
Betreff: RE: [Kea-users] KEA DHCP and VLANS...

Hi,

it’s never a good idea to mix untagged (native vlan 1) and tagged packets. I suggest you change your network layout, this will prevent you from many more phenomenons.

Cheers,

               Tom

p.s.: if you cannot do it easily, than set up a dhcp-relay for native vlan on the switch and relay it to the KEA in a separate vlan

From: Kea-users [mailto:kea-users-bounces at lists.isc.org] On Behalf Of Talkabout
Sent: Saturday, February 1, 2020 2:12 PM
To: kea-users at lists.isc.org
Subject: Re: [Kea-users] KEA DHCP and VLANS...

Hi all,

I think the Problem here is the physical interface. It seems that for every virtual interface the dhcp request is also delivered to eth0, which makes the DHCP Server to try to advertise ips from the vlan and lan. Depending on the Client the correct or wrong ip is accepted.

Question: is KEA DHCP Server honoring the vlan Tagging? In such a case it should not accept the DHCP requests on eth0 if the request is tagged with a particuar vlan.

Thanks!

Gesendet von Mail für Windows 10

Von: Talkabout
Gesendet: Samstag, 1. Februar 2020 12:36
An: kea-users at lists.isc.org
Betreff: [Kea-users] KEA DHCP and VLANS...

Hi guys,

I am struggling in getting my KEA DHCP Server to work with my VLAN Environment. I was assuming that defining a list of virtual interfaces and subnets matching those is sufficient, but it seems that the „dhcp-socket-type: raw“ is skipping the VLAN handling in the Linux kernel and thus this Information is Kind of lost… I have read a lot About Client classes, shared Networks and so on but I have not found any solution in how to get the DHCP Server to assign correct ip pools based on the VLAN. Here is my configuration:

Interfaces:

eth0 => physical interface
eth0.30 => virtual interface
eth0.50 => virtual interface
eth0.100 => virtual interface

KEA DHCP conf:

{
        "Dhcp4": {
                "interfaces-config": {
                        "interfaces": [ "eth0", "eth0.30", "eth0.50", "eth0.100" ],
                        "dhcp-socket-type": "raw"
                },
                "control-socket": {
                        "socket-type": "unix",
                        "socket-name": "/tmp/kea4-ctrl-socket"
                },
                "lease-database": {
               …
                },
                "hosts-database": {
               …
                },
                "sanity-checks": {
                        "lease-checks": "fix-del"
                },
                "valid-lifetime": 28800,
                "rebind-timer": 21600,
                "subnet4": [
                        {
                                "pools": [
                                        {
                                                "pool": "192.168.20.100-192.168.20.200"
                                        }
                                ],
                                "id": 1,
                                "subnet": "192.168.20.0/24",
                                "interface": "eth0",
                                "option-data": [
                       …
                                ]
                        },
                        {
                                "pools": [
                                        {
                                                "pool": "192.168.30.100-192.168.30.200"
                                        }
                                ],
                                "id": 30,
                                "subnet": "192.168.30.0/24",
                                "interface": "eth0.30",
                                "option-data": [
                       …
                                ]
                        },
                        {
                                "pools": [
                                        {
                                                "pool": "192.168.50.100-192.168.50.200"
                                        }
                                ],
                                "id": 50,
                                "interface" : "eth0.50",
                                "subnet": "192.168.50.0/24",
                                "option-data": [
                       …
                                ]
                        },
                        {
                                "pools": [
                                        {
                                                "pool": "192.168.100.100-192.168.100.200"
                                        }
                                ],
                                "id": 100,
                                "subnet": "192.168.100.0/24",
                                "interface": "eth0.100",
                                "option-data": [
                       …
                                ]
                        }
                ],
                "hooks-libraries": [
               …
                ],
                "loggers": [
                        …
                ]
        }
}

What do I Need to do to force the DHCP Server to assign an IP address from a subnet based on the tagged VLAN of the request?

I am using KEA DHCP Server Version 1.6.1.

Help is much appreciated!

Thanks!

Gesendet von Mail für Windows 10



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20200201/8306aca1/attachment-0001.htm>


More information about the Kea-users mailing list