[Kea-users] Kea 1.1-epel conf no longer work with kea 1.6

Stephan_Walter Stephan.walter at emea.nec.com
Wed Feb 26 17:07:04 UTC 2020


Hi,

I moved from the kea 1.1 server, provided through the epel repo of CentOS7,
to a kea 1.6 server compiled on CentOS8 from srpm.

The new kea worked from the beginning, but when I tried to boot nodes, they
received the wrong boot-file from the kea. Let me show the relevant part of
the kea config.


{
  "Dhcp4": {
 ...
        "option-data": [ ],
        "client-classes": [
        {
          "name": "INODE",
          "test": "substring(option[60].hex,0,4) == 'udhcp'",
          "boot-file-name": "somefancy\n\\,string=now"
        },
            {
                "name": "bios",
                "test": "option[93].hex == 0x0000",
                "boot-file-name": "/tftp/bios/lpxelinux.0"
            },
            {
                "name": "ipxe_efi64",
                "test": "option[93].hex == 0x0007",
                "boot-file-name": "/tftp/efi64/ipxe.efi"
            },
            {
                "name": "efi64",
                "test": "option[93].hex == 0x0009",
                "boot-file-name": "/tftp/efi64/bootx64.efi"
            }
         ],
        "subnet4": [
            {
                "subnet": "10.0.0.1/16",
                "reservations": [
{ "hw-address": "XX:XX:XX:XX:XX:XX", "ip-address": "10.0.2.1",
"next-server": "10.0.103.22", "hostname": "some_node", "client-classes":
["NODE"], "server-hostname": "10.0.103.42"},
                ]
   ....

}


So with kea 1.1 the behavior is, that the system boots through PXE and get
"/tftp/..." as boot-file-name. Afterward, the system make again a DHCP
request and now get the "somefancy.." string as boot-file-name, that it use
to fetch additional data for a two stage boot

With kea 1.6 already in the first response the "somefancy..." string is
replied as boot-file-name, what lead to a non working PXE boot.

I tried now for several days without success to figure out what has changed. 

What I have found is:


But even after a reordering of the client class definition, so that the pxe
boot is at the top, the problem still occurs.

Anybody an idea how I can get with kea 1.6 the same behavior as with 1.1?



--
Sent from: http://kea-users.7364.n8.nabble.com/


More information about the Kea-users mailing list