<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri",sans-serif;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link="#0563C1" vlink="#954F72"><div class=WordSection1><p class=MsoNormal>Hello,<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>I forgot to install the latest gcc 4.9 before I installed Kea 1.5.  I now have gcc 4.9 installed, however, after going through all the installation step again for installing from source with sysrepo on Centos 7 I receive the following error when I try the following commands – “make -j4” ( also tried “make” by itself) and also “make install” <o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>I have also tried “make uninstall” followed by “make install”…. Which did not help …. And also tried “make -j4” followed by “make install” to no resolution.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>make[2]: Leaving directory `/root/kea-1.5.0/src/lib'<o:p></o:p></p><p class=MsoNormal>Making install in bin<o:p></o:p></p><p class=MsoNormal>make[2]: Entering directory `/root/kea-1.5.0/src/bin'<o:p></o:p></p><p class=MsoNormal>Making install in dhcp4<o:p></o:p></p><p class=MsoNormal>make[3]: Entering directory `/root/kea-1.5.0/src/bin/dhcp4'<o:p></o:p></p><p class=MsoNormal>make  install-recursive<o:p></o:p></p><p class=MsoNormal>make[4]: Entering directory `/root/kea-1.5.0/src/bin/dhcp4'<o:p></o:p></p><p class=MsoNormal>Making install in .<o:p></o:p></p><p class=MsoNormal>make[5]: Entering directory `/root/kea-1.5.0/src/bin/dhcp4'<o:p></o:p></p><p class=MsoNormal>  CXXLD    kea-dhcp4<o:p></o:p></p><p class=MsoNormal>./.libs/libdhcp4.a(dhcp4_parser.o): In function `isc::dhcp::Dhcp4Parser::parse()':<o:p></o:p></p><p class=MsoNormal>/root/kea-1.5.0/src/bin/dhcp4/dhcp4_parser.yy:2074: undefined reference to `operator delete(void*, unsigned long)'<o:p></o:p></p><p class=MsoNormal>/root/kea-1.5.0/src/bin/dhcp4/dhcp4_parser.yy:278: undefined reference to `operator delete(void*, unsigned long)'<o:p></o:p></p><p class=MsoNormal>/root/kea-1.5.0/src/bin/dhcp4/dhcp4_parser.yy:279: undefined reference to `operator delete(void*, unsigned long)'<o:p></o:p></p><p class=MsoNormal>/root/kea-1.5.0/src/bin/dhcp4/dhcp4_parser.yy:601: undefined reference to `operator delete(void*, unsigned long)'<o:p></o:p></p><p class=MsoNormal>/root/kea-1.5.0/src/bin/dhcp4/dhcp4_parser.yy:1984: undefined reference to `operator delete(void*, unsigned long)'<o:p></o:p></p><p class=MsoNormal>./.libs/libdhcp4.a(dhcp4_parser.o):/root/kea-1.5.0/src/bin/dhcp4/dhcp4_parser.yy:1687: more undefined references to `operator delete(void*, unsigned long)' follow<o:p></o:p></p><p class=MsoNormal>../../../src/lib/cc/.libs/libkea-cc.so: undefined reference to `std::runtime_error::runtime_error(char const*)'<o:p></o:p></p><p class=MsoNormal>collect2: error: ld returned 1 exit status<o:p></o:p></p><p class=MsoNormal>make[5]: *** [kea-dhcp4] Error 1<o:p></o:p></p><p class=MsoNormal>make[5]: Leaving directory `/root/kea-1.5.0/src/bin/dhcp4'<o:p></o:p></p><p class=MsoNormal>make[4]: *** [install-recursive] Error 1<o:p></o:p></p><p class=MsoNormal>make[4]: Leaving directory `/root/kea-1.5.0/src/bin/dhcp4'<o:p></o:p></p><p class=MsoNormal>make[3]: *** [install] Error 2<o:p></o:p></p><p class=MsoNormal>make[3]: Leaving directory `/root/kea-1.5.0/src/bin/dhcp4'<o:p></o:p></p><p class=MsoNormal>make[2]: *** [install-recursive] Error 1<o:p></o:p></p><p class=MsoNormal>make[2]: Leaving directory `/root/kea-1.5.0/src/bin'<o:p></o:p></p><p class=MsoNormal>make[1]: *** [install-recursive] Error 1<o:p></o:p></p><p class=MsoNormal>make[1]: Leaving directory `/root/kea-1.5.0/src'<o:p></o:p></p><p class=MsoNormal>make: *** [install-recursive] Error 1<o:p></o:p></p></div></body></html>