<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.E-mailStlus17
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 70.85pt 2.0cm 70.85pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=HU link=blue vlink="#954F72"><div class=WordSection1><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>Hi,<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>that’s why I’ve written the dirty workaround. Since you’ve only trouble with the native vlan, than a possible solution is to ’tag’ the native vlan with a crosslink on the swicht (looping back to itself). This way you can tag the native vlan transparently.<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>So you create a new vlan – vlan 20 let’s say – remove the ip from the pysical interface and assign it to interface vlan20. On the switch you cross connect a native vlan port with a vlan 20 access port „bridgeing”  it together (all packets in the native vlan will appear to KEA as vlan 20 packets).<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>With openvswitch you’ll to nearly the same, but virtually. If openvswitch honors the tagged/untagged scenario correctly, than it’ll work.<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>Cheers,<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'>               Tom<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D;mso-fareast-language:EN-US'><o:p> </o:p></span></p><div><div style='border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal><b>From:</b> Kea-users [mailto:kea-users-bounces@lists.isc.org] <b>On Behalf Of </b>Talkabout<br><b>Sent:</b> Sunday, February 2, 2020 7:42 PM<br><b>To:</b> Oehlrich, Benedikt <boe@codemanufaktur.com><br><b>Cc:</b> kea-users@lists.isc.org<br><b>Subject:</b> Re: [Kea-users] KEA DHCP and VLANS...<o:p></o:p></p></div></div><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal><span lang=DE>Hi Ben,<o:p></o:p></span></p><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p><p class=MsoNormal><span lang=DE>in my case I think the prerequisite is a Little bit different. I already have 3 vlans on the dhcp Server, and if I configure only those for dhcp then everything works as expected. The Problem occurs when I want to add the physical device (eth0, untagged) to dhcp, because then, as KEA dhcp Server binds in „raw“ mode, untagged and tagged traffic is delivered via this interface. Because the implementation in KEA dhcp Server does not correctly handle this „mixed“ (untagged/tagged) traffic, it is assigning incorrect ips. I am not sure if using openvswitch can solve that for me.<o:p></o:p></span></p><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p><p class=MsoNormal><span lang=DE>My hope is that the KEA Team will take care of that and fix it, because in my eyes this is a bug and big Limitation.<o:p></o:p></span></p><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p><p class=MsoNormal><span lang=DE>Thanks!<o:p></o:p></span></p><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p><p class=MsoNormal><span lang=DE>Gesendet von <a href="https://go.microsoft.com/fwlink/?LinkId=550986">Mail</a> für Windows 10<o:p></o:p></span></p><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p><div style='border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal><b><span lang=DE>Von: </span></b><span lang=DE><a href="mailto:boe@codemanufaktur.com">Oehlrich, Benedikt</a><br><b>Gesendet: </b>Sonntag, 2. Februar 2020 19:25<br><b>An: </b><a href="mailto:talk.about@gmx.de">Talkabout</a><br><b>Cc: </b><a href="mailto:viper@vipernet.hu">Dajka Tamás</a>; <a href="mailto:kea-users@lists.isc.org">kea-users@lists.isc.org</a><br><b>Betreff: </b>Re: [Kea-users] KEA DHCP and VLANS...<o:p></o:p></span></p></div><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p><div><div><p class=MsoNormal><span lang=DE>Hey,<o:p></o:p></span></p></div><div><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p></div><div><p class=MsoNormal><span lang=DE>I sadly don't have any information about the openvswitch configuration, as I started to work on our DHCP when we migrated to the relay based solution.<o:p></o:p></span></p></div><div><p class=MsoNormal><span lang=DE>But from my understanding you will get multiple interfaces e.g vlan30, vlan100 etc. where you only get the traffic from the specified vlans. That means if you have one connection from your switch to your dhcp server where all tagged vlan traffic is going through, you can get the untagged traffic separated into the openvswitch interfaces. <o:p></o:p></span></p></div><div><p class=MsoNormal><span lang=DE>These interfaces will then be handled like in your first emails kea configuration.<o:p></o:p></span></p></div><div><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p></div><div><p class=MsoNormal><span lang=DE>Cheers,<o:p></o:p></span></p></div><div><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p></div></div><p class=MsoNormal><span lang=DE><o:p> </o:p></span></p><div><div><p class=MsoNormal><span lang=DE>Am Sa., 1. Feb. 2020 um 23:15 Uhr schrieb Talkabout <<a href="mailto:talk.about@gmx.de">talk.about@gmx.de</a>>:<o:p></o:p></span></p></div><blockquote style='border:none;border-left:solid #CCCCCC 1.0pt;padding:0cm 0cm 0cm 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0cm;margin-bottom:5.0pt'><div><div><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'><span lang=DE>Hi Ben,<o:p></o:p></span></p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'><span lang=DE> <o:p></o:p></span></p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'><span lang=DE>this sounds interesting. Can you give some more Information how you configured your System to work that way? I am running Debian Buster Linux Distribution and openvswitch seems to be available in the repos. In my case what I Need is Forwarding untagged traffic from eth0 to a new interface eth0.x which is tagged and can be used by KEA to handle DHCP requests.<o:p></o:p></span></p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'><span lang=DE> <o:p></o:p></span></p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'><span lang=DE>Thanks!<o:p></o:p></span></p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'><span lang=DE> <o:p></o:p></span></p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto;margin-left:11.55pt'><span lang=DE>Gesendet von <a href="https://go.microsoft.com/fwlink/?LinkId=550986" target="_blank">Mail</a> für Windows 10<o:p></o:p></span></p></div></div></blockquote></div></div></body></html>