<html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:70.85pt 70.85pt 2.0cm 70.85pt;}
div.WordSection1
        {page:WordSection1;}
--></style></head><body lang=DE link=blue vlink="#954F72"><div class=WordSection1><p class=MsoNormal>Hi Ben,</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>in my case I think the prerequisite is a Little bit different. I already have 3 vlans on the dhcp Server, and if I configure only those for dhcp then everything works as expected. The Problem occurs when I want to add the physical device (eth0, untagged) to dhcp, because then, as KEA dhcp Server binds in „raw“ mode, untagged and tagged traffic is delivered via this interface. Because the implementation in KEA dhcp Server does not correctly handle this „mixed“ (untagged/tagged) traffic, it is assigning incorrect ips. I am not sure if using openvswitch can solve that for me.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>My hope is that the KEA Team will take care of that and fix it, because in my eyes this is a bug and big Limitation.</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Thanks!</p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Gesendet von <a href="https://go.microsoft.com/fwlink/?LinkId=550986">Mail</a> für Windows 10</p><p class=MsoNormal><o:p> </o:p></p><div style='mso-element:para-border-div;border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal style='border:none;padding:0cm'><b>Von: </b><a href="mailto:boe@codemanufaktur.com">Oehlrich, Benedikt</a><br><b>Gesendet: </b>Sonntag, 2. Februar 2020 19:25<br><b>An: </b><a href="mailto:talk.about@gmx.de">Talkabout</a><br><b>Cc: </b><a href="mailto:viper@vipernet.hu">Dajka Tamás</a>; <a href="mailto:kea-users@lists.isc.org">kea-users@lists.isc.org</a><br><b>Betreff: </b>Re: [Kea-users] KEA DHCP and VLANS...</p></div><p class=MsoNormal><o:p> </o:p></p><div><div><p class=MsoNormal>Hey,</p></div><div><p class=MsoNormal><o:p> </o:p></p></div><div><p class=MsoNormal>I sadly don't have any information about the openvswitch configuration, as I started to work on our DHCP when we migrated to the relay based solution.</p></div><div><p class=MsoNormal>But from my understanding you will get multiple interfaces e.g vlan30, vlan100 etc. where you only get the traffic from the specified vlans. That means if you have one connection from your switch to your dhcp server where all tagged vlan traffic is going through, you can get the untagged traffic separated into the openvswitch interfaces. </p></div><div><p class=MsoNormal>These interfaces will then be handled like in your first emails kea configuration.</p></div><div><p class=MsoNormal><o:p> </o:p></p></div><div><p class=MsoNormal>Cheers,</p></div><div><p class=MsoNormal><o:p> </o:p></p></div></div><p class=MsoNormal><o:p> </o:p></p><div><div><p class=MsoNormal>Am Sa., 1. Feb. 2020 um 23:15 Uhr schrieb Talkabout <<a href="mailto:talk.about@gmx.de">talk.about@gmx.de</a>>:</p></div><blockquote style='border:none;border-left:solid #CCCCCC 1.0pt;padding:0cm 0cm 0cm 6.0pt;margin-left:4.8pt;margin-right:0cm'><div><div><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'>Hi Ben,</p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'> </p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'>this sounds interesting. Can you give some more Information how you configured your System to work that way? I am running Debian Buster Linux Distribution and openvswitch seems to be available in the repos. In my case what I Need is Forwarding untagged traffic from eth0 to a new interface eth0.x which is tagged and can be used by KEA to handle DHCP requests.</p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'> </p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'>Thanks!</p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto'> </p><p class=MsoNormal style='mso-margin-top-alt:auto;mso-margin-bottom-alt:auto;margin-left:11.55pt'>Gesendet von <a href="https://go.microsoft.com/fwlink/?LinkId=550986" target="_blank">Mail</a> für Windows 10</p></div></div></blockquote></div></div></body></html>