Weird nslookup problem (from O'Reilly book, page 84)

Chris chris at
Mon Nov 8 17:01:05 UTC 1999

> has an incorrect CNAME record cached:
>	813	CNAME
>You would have seen this if you used "dig" rather than the inferior
>"nslookup" in your troubleshooting.  That record should time out in about
>10 minutes.

Thinking back, I think I did try www, at gatekeeper, and when it
failed (because it had hossie instead of hoss, I corrected my RR file,
but www still failed. A caching of a incorrect record would explain
why www failed but the equivalent ftp and mail (which I didn't look
for until I made the corrections) succeeded. I'll also look into dig -
it appears my system has it, so I'll figure out how to use it instead
of nslookup.

>I tried your ISP's server and it worked OK.  I also got the correct answer
>with my local server.
>However, I noticed that the domain I see when I query your server is not
>quite the same as what you posted.  Your actual SOA record has serial
>number 1, but you posted serial number 199909283.  Your secondary server,
>bessie, is down at the moment.  It's possible that the bad CNAME record was
>coming from it; if you changed your serial number from 199909283 to 1,
>bessie would not have done a zone transfer (zone transfers happen only when
>the serial number increases).

I switched serial number schemes when I saw that the D&B bok was using
1, 2, 3 instead of a date-revision number quasi-hash, and I liked the
simple scheme better. I know I switched from a big number to a small
number, but since I don't actually have a secondary server running
(there have been some hardware delays), I don't think anything has
loaded that big serial number, so I'm assuming it won't be a problem.

Thanks Barry,

More information about the bind-users mailing list