Weird nslookup problem (from O'Reilly book, page 84)

Barry Margolin barmar at
Mon Nov 8 16:23:46 UTC 1999

In article <3825b19a.1151259 at>,
Chris <chris at> wrote:
>What I'm trying to find is My default domain is
>, and nslookup www works fine. nslookup
> fails though, as does nslookup
> (that's my ISP's name server). What's
>strange is that doing the same nslookups with, or
>other hosts works fine. Only www fails. has an incorrect CNAME record cached:	813	CNAME

You would have seen this if you used "dig" rather than the inferior
"nslookup" in your troubleshooting.  That record should time out in about
10 minutes.

I tried your ISP's server and it worked OK.  I also got the correct answer
with my local server.

However, I noticed that the domain I see when I query your server is not
quite the same as what you posted.  Your actual SOA record has serial
number 1, but you posted serial number 199909283.  Your secondary server,
bessie, is down at the moment.  It's possible that the bad CNAME record was
coming from it; if you changed your serial number from 199909283 to 1,
bessie would not have done a zone transfer (zone transfers happen only when
the serial number increases).

Barry Margolin, barmar at
GTE Internetworking, Powered by BBN, Burlington, MA
Please DON'T copy followups to me -- I'll assume it wasn't posted to the group.

More information about the bind-users mailing list