BIND Zone XFER Problems

Peter Ziemann ziemann.nortel-dasa at
Thu Mar 2 13:58:36 UTC 2000


this is not the problem. I have tried to change the serial number
to a Y2K compliant format - same result.

Furtheron I have removed the TXT records as well as more and
more CNAME records. At the end it worked at one point (when
I have removed enough CNAME records ...).

This seems to be a BIND bug, and I have opened an error report.

It it also not a problem of my machine - like a wrong MTU value -
since Web-Server, E-Mail Server, DHCP-Server, FTP / TELNET
and all other components of BIND work perfectly.


Peter Ziemann, hostmaster at

Mike Dimmick <mike at> wrote in message
news:951938922.9684.2.nnrp-07.d4e5bde1 at
> "Peter Ziemann" <ziemann.nortel-dasa at> wrote in message
> news:8888ss$co1$1 at
> > Yes, but I have modified my zone file until I got it working
> > (took me several hours trial-and-error). I have also tried
> > before several BIND options - no change. Furtheron I
> > have recompiled the whole BIND 8.2.2-P5 distribution
> > and observed no errors & warning - again no change.
> >
> > I still do not know what the problem is. I think I will write a
> > BUG REPORT for BIND 8.2.2-P5 & will help to trace down
> > the problem with my environment/configuration.
> I tried a diff on the two files and the only significant difference was
> in the SOA: old (non-working) serial was 00021010, new (working) serial
> 2000021010.  Perhaps some piece of software doesn't like very small
> serial numbers?  The other differences were the removal of MX and CNAME
> records for all the hosts (but if you want this behaviour - same MX for
> all hosts - surely a wildcard is more appropriate?) and the removal of
> the TXT record.
> --
> Mike Dimmick

More information about the bind-users mailing list