Fails 1st, works 2nd?

Sam Yee sam at
Thu Mar 23 22:46:49 UTC 2000

In article <38C88772.3128828D at>, Jerry Williams <jwilliam at> wrote:
>I have Bind8.2.2p5 running on a linux box.  It is a master/slave and
>uses forwarders.  When I query something that isn't in cache I get a
>No response from server error.  When I try it again it works.
>This is only for things that I am not a master/slave. ie offsite
>internet names.
>But it doesn't always do this.  I have tried to turn debugging on,
>but am not sure what I am looking at.  I have tried using nslookup
>against the forwarders and they seem to work ok, but this is hard to
>test because of the caching.  The only other thing that I can think
>to do is to stop using forwarders and see if that makes any difference.
>Any suggestions would be greatly appreciated.

The first lookup could take a long time because the answer is not in the 
cache.  nslookup just times out before the response from the remote server 
came back.  When you try nslookup again the DNS responds immediately
because the answer is in the cache.

Hope that helps.


More information about the bind-users mailing list