strange log?

digitalfrontier digitalfrontier at
Tue Mar 13 14:28:20 UTC 2001

I'm running RH 6.2 this is odd,..i installed BIND 8.2.3 from scratch,

make clean
make depend
mak all
make install

and BEFORE doing 'make install' I deleted the .settings file in the src dir
and edited the /src/port/linux Makefile.set to alter the DESTINATION dir to
/usr/local/bind823 and its child dir


afer this,...I placed the startup script call named in /etc/rc.d/init.d/
then I ran chkconfig --add named
chkconfig --level 345 named on

all went fine at this point,...but here is where it gets wierd, after
starting the named daemon by running
/etc/rc.d/init.d/named start
which went fine and started ok.....but what was strange was it created a log
file in /root called 'foo'

i used jove to open it,.and yep, it was a log file for the named daemon,
I went ahead and deleted it, but every time i start up the named daemon
using /etc/rc.d/init.d/named start it re-created it but when i just start
named with the path like /usr/local/bind823/sbin/named -u named
it doesn't create this 'foo' named log

AND on top of that, I ran NMAP on my ip and it showed domain on port 53 but
also something called xns-time on port 52 i checked to see what process
was using this port and sure enough, it was the named daemom.

WHATS going on here??...any thoughts??,..I'm truly baffled



 An optimist believes we live in the best of all  possible worlds.  A
pessimist is sure of it!

Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (
Version: 6.0.237 / Virus Database: 115 - Release Date: 3/7/2001

More information about the bind-users mailing list