strange log?

Joseph S D Yao jsdy at
Tue Mar 13 20:55:22 UTC 2001

On Tue, Mar 13, 2001 at 09:28:20AM -0500, digitalfrontier wrote:
> I'm running RH 6.2 this is odd,..i installed BIND 8.2.3 from scratch,
> running
> make clean
> make depend
> mak all
> make install
> and BEFORE doing 'make install' I deleted the .settings file in the src dir
> and edited the /src/port/linux Makefile.set to alter the DESTINATION dir to
> /usr/local/bind823 and its child dir
> DESTSBIN=/usr/local/bind823/sbin
> DESTBIN/usr/local/bind823/bin
> etc,..etc.....
> afer this,...I placed the startup script call named in /etc/rc.d/init.d/
> then I ran chkconfig --add named
> chkconfig --level 345 named on
> all went fine at this point,...but here is where it gets wierd, after
> starting the named daemon by running
> /etc/rc.d/init.d/named start
> which went fine and started ok.....but what was strange was it created a log
> file in /root called 'foo'
> i used jove to open it,.and yep, it was a log file for the named daemon,
> I went ahead and deleted it, but every time i start up the named daemon
> using /etc/rc.d/init.d/named start it re-created it but when i just start
> named with the path like /usr/local/bind823/sbin/named -u named
> it doesn't create this 'foo' named log

You COMPILED IN one set of directories.  You then moved the files into
a DIFFERENT set of directories.  It is crying "help" in a thin, squeaky
voice, since the universe as it was told about and built for is not the
universe in which it is running.  And who did this to it?  ;-)  Of
course, when you limit it, it can't do anything.

> AND on top of that, I ran NMAP on my ip and it showed domain on port 53 but
> also something called xns-time on port 52 i checked to see what process
> was using this port and sure enough, it was the named daemom.

Well, 'named' uses a random source port for queries, but I had thought
that it was a higher one.  52 is not a standard port for it to use.

Joe Yao				jsdy at - Joseph S. D. Yao
COSPO/OSIS Computer Support					EMT-B
This message is not an official statement of COSPO policies.

More information about the bind-users mailing list