dig @localhost ok but not @hostname.dom.ain

mr king mrking01 at hotmail.com
Fri Mar 16 18:15:31 UTC 2001

i've been running 9.1.0 chrooted on a slave for a few weeks now and just 
upgraded the master to 9.1.0 last night.  today i was told the slave wasn't 
responding to queries.  i got "...no servers could be reached" from dig 
@slave.dom.ain. and after looking at it for a while tried dig @localhost and 
got a response back.  netstat showed port 53 open on localhost and the 
hostname.  i know there were some problems with syntax errors in the zone 
file that the master and slave belong to on the master last night so i 
thought the slave may have gotten one on a transfer and failed to load it 
and maybe no being able to resolve it's own name was causing problems (there 
was nothing in the logs).  so i tried `rndc reload` and that didn't help.  i 
eventually just killed the process and restarted it and everything was fine. 
  i checked the listing of zone files against an earlier `ls -l` and it 
didn't look like anything had changed.  can someone give me some ideas on 
what might have happened?
Get your FREE download of MSN Explorer at http://explorer.msn.com

More information about the bind-users mailing list