Can't find server name for address xxx

Kevin Darcy kcd at
Sat Mar 17 01:23:05 UTC 2001

/etc/hosts plays no part here, and the /etc/resolv.conf contents just confirms
that nslookup is failing over to the second nameserver because it's having
trouble using the first one.

By the way, why did you attempt to "anonymize" the names and addresses of ( and ( Was there
something you hoped to accomplish by doing that? All it did is make
troubleshooting this problem slightly harder than it would have been otherwise.

In any case, as you can see, the first nameserver that nslookup tried has an
address in a *different* range than the second nameserver that it tried. It just
so happens that the reverse zone for the 216.37.47.* address range is totally
broken (all of the delegated nameservers return SERVFAIL), but the reverse zone
for the 216.37.14.* range is OK.

Note that if you had used "dig" instead of nslookup, then the inability to
reverse-resolve the first nameserver's address wouldn't have caused a failover
to the second nameserver. This is just one of the many ways in which nslookup

- Kevin

news-no-spam-group at wrote:

> I know I've seen this posted here before, but never had problem before and
> can't find it when searching past postings.
> [root at nsx /etc]# nslookup
> *** Can't find server name for address 2xx.xx.xx1: Server failed
> Default Server:
> Address:  2xx.xx.xx2
> Linux RH6.1
> Bind bind-8.2.3-0.5.x
> MY /etc/resolv.conf
> domain
> nameserver 2xx.xx.xx1
> nameserver 2xx.xx.xx2
> nameserver 2xx.xx.xx3
> MY /etc/hosts FILE:
>               localhost.localdomain localhost
>  nsx
> I am on the road and must solve this problem remotely over the weekend... so
> an email in addition to posting would be greatly appreciated - don't know how
> much newgroup access I will have for the next few days, so please email
> "a994955454" at the great, ya right,
> Thank you,
> Rick

More information about the bind-users mailing list