can't exec /usr/sbin/named-xfer no such file or directory

Kevin Darcy kcd at
Sat Mar 17 00:59:49 UTC 2001

The path should be chroot()-relative, since named is already chroot()'ed when
it tries to exec named-xfer. Are you *absolutely* sure that you have a copy of
named-xfer at {chroot()-apex}/usr/sbin/named-xfer? Do you possibly have any
symlinks anywhere along that path?

- Kevin

ja wrote:

> That's the message in my logs. I chrooted bind and no matter what will i do
> it's always the same. I tried to set named-xfer path in named.conf but it
> doesn't change anything. Of course the file is there and has rx attribute
> for all as all directories. In act of despair i copied named-xfer executable
> in every directory it could be searching and, as you can guess it didn't
> work. I even tried to set non relative path to chroot cage but it also
> didn't helped.
> I'm running Debian Potato and bind 8.2.3 on i486. Strange thing is that I
> also chrooted it on my second box (Alpha 2000 DEC 500 same debian), and it
> works without complaints. Firtst I thought it was my fault, some mispelling
> in paths or something like that. I rechecked it 4 times and all changes are
> the same on both.
> Thanks in advance
> JA

More information about the bind-users mailing list