BIND8 to BIND9 anomaly

Bob Vance bobvance at
Sat Mar 31 19:46:53 UTC 2001

I just noticed a mild quirk of going to BIND 9.1.1.

On a test server, running 8.2.3-rel, I had an empty root hints file, at
least it was nothing but comments.
Since I'm using forwarders, I don't care about root servers.

Anyway, BIND8 didn't mind and loaded and worked fine, answering his own
zones authoritatively and forwarding for the rest.

pluto# dig

would return correct data.

But, when I loaded BIND 9.1.1, the
refused to forward, returning a SERVFAIL error.
I could do a
    'dig @<forwarder>'
just fine and 'named' still answered it's own stuff authoritatively.

I set debug level to 100  ( :)  but there was nothing mentioned about a
hints problem and all that is logged on the request is a simple
in the client attach logic:

security: debug 3: client recursion approved
client: debug 3: client query
client: debug 10: client ns_client_attach: ref = 1
security: debug 3: client query approved
client: debug 3: client error
client: debug 3: client send

Anyway, I just removed the "hints" zone and that fixed the problem.

I also tried adding some trash to the cache file:

.       99999999    IN  NS  root.server.
root.server.    99999999    IN  A

and that also worked !!!!

Tks        | <mailto:BVance at>
BV         | <mailto:BobVance at>
Sr. Technical Consultant,  SBM, A Gates/Arrow Co.
Vox 770-623-3430           11455 Lakefield Dr.
Fax 770-623-3429           Duluth, GA 30097-1511

More information about the bind-users mailing list