Bind not starting properly

Pete Ehlke pde at
Wed Oct 10 18:28:25 UTC 2001

* Roman Kubiak <a_tom at> said, on [011010 07:54]:
> I have a problem with Bind 8.2.3 (standard Slackware 7.2 package)
> Bind starts up, reads config files, listens on all interfaces but does not
> respond to any requests localy or remotly. It only happens during boot, when
> i login as root and do ndc restart named works fine responds to all
> requests. I tried to restart named a couple of times during the boot process
> but that didn't help. I straced it and got a
> resource temporarily unavailable on recvfrom () function.
> It says in the init scripts that you should run named as root, because it
> has problems with listening on dynamic interfaces like PPP, well
> i have two of those (two ericsson modems-HIS). But I run named as root
> (though thats not a good idea). Well if someone could tell me how to get
> named to work during boot without no restarting.

I imagine that named is being started before your PPP interfaces are up. 

More information about the bind-users mailing list