9.1.1 reverse lookup problem

Kevin Darcy kcd at daimlerchrysler.com
Tue Oct 16 22:30:57 UTC 2001

There should be no differences between BIND 9 and earlier BIND versions in
this regard, as long as the zonefile data is kosher. The only difference
that I could imagine possibly being relevant here is that BIND 9 is pickier
than its predecessors about zonefile contents, and will gag more easily on
illegal contents. If, for example, you delegated 8.1.10.in-addr.arpa from
10.in-addr.arpa *and* tried to include PTR records in the 10.in-addr.arpa
zonefile where were in the 10.1.8.* range, then those records may have been
accepted by earlier versions of BIND, but BIND 9 will (rightfully) reject
those records as "out of zone data".

- Kevin

Jeff Jones wrote:

> I hope I can explain this without being too confusing.  All our internal
> IP addresses are from the
> class A address block.  With older versions of DNS I could use
> one reverse lookup file
> such as 10.in-addr.arpa for example.  Now with 9.1.1 it appears that it
> wants to treat the class A
> address block like a class C address block concerning reverse lookups.
> So, if I do a reverse lookup
> on say, DNS is looking for a reverse file on
> 8.1.10.in-addr.arpa for example.  Is this just
> how it works now?  If so, I can make the changes, but right now I just
> have one reverse lookup file
> for all addresses in the range and it doesn't work unless I
> break them out as mentioned above.
> Thanks.

More information about the bind-users mailing list