refresh_callback or rndc: connect: connection refused

Danny Mayer mayer at
Fri Jun 14 02:17:31 UTC 2002

At 10:39 PM 6/9/02, gaius.petronius wrote:

>system (Linux RH 7.1) running BIND 9.1
>service named start
>Starting named:                                            [  OK  ]
>service named status
>rndc: connect: connection refused

That means that nothings listening on the command channel port (default 953)
the rndc is using to access named.  If named is running you didn't
set up the controls to have it listen for rndc requests. Check the ARM
on this.

>The system has been running straight for a year serving DNS.  about 3
>weeks ago the machine began to crash every 2-3 days.  No configuration
>changes have been made to the system, and there are no space problems.
>  Now DNS is crashing every few minutes.  i have moved DNS to another
>The logs say
>Jun 10 10:27:17 dns1 named[11999]: listening on IPv4 interface eth0,
>[this machine ip address]#53
>Jun 10 10:27:17 dns1 named[11999]: binding TCP socket: address in use
>Jun 10 10:27:17 dns1 named[11999]: running
>Jun 10 10:27:17 dns1 named[11999]: refresh_callback: zone
>[domain].com/IN: non-authoritative answer from [master dns ip
>Apparently at this point dies

Find out why the master is not authorative.  You may have bad records
in the zone.  Check the master's log files.

>i want to get BIND to run at the debug level of most detail but still
>run it from the service command: service named start
>sysVinit files run from the runlevel links, /etc/init.d/[service] so i
>/etc/sysconfig/named to add -d 9
>This didn't work:
>service named start
>/etc/init.d/named: -d: command not found
>Starting named:                                            [  OK  ]
>so i ran it from the commandline named -d 9
>Still no further information
>grep named /var/log/messages
>Jun 10 10:40:56 dns1 named[12253]: listening on IPv4 interface eth0
>Jun 10 10:40:56 dns1 named[12253]: running
>Jun 10 10:40:57 dns1 named[12253]: refresh_callback: zone
>[domain].com/IN: non-authoritative answer from [master dns ip]#53
>[root at dns1 /root]# service named status
>/etc/init.d/named: -d: command not found
>rndc: connect: connection refused
>where do i go from here?
>the easy solution might be to reinstall BIND
>but that is the wrong answer

Find out first what is wrong with the master's zone. Use named-checkzone
on the master's zone file and look at its log files.


More information about the bind-users mailing list