Even Stranger Incorrect DNS Query Results

phn at icke-reklam.ipsec.nu phn at icke-reklam.ipsec.nu
Wed Dec 8 16:24:34 UTC 2004

Allie M Hopkins <allie at lsu.edu> wrote:

> I have a stranger problem.. one that may end up being reported to IBM, but
> I figured I give the list a shot.

> A user started complaining of not being able to send mail to a particular
> domain (bergstedtandmount.com).  The problem is that our name servers can
> not resolve that name off the responsible name server.  After digging for a
> full day, this is what I found:

> ANY aix machine that I run dig @ns1.ntwo.net any.thing.com times out.  I
> have tried 6 different aix machines with varying hardware, os version,
> software, administrators, etc.  All fail.  On ANY other os that I try:
> windows, openbsd, fedora, gentoo, this lookup is successful.  How strange
> is that?????  I dug a little deeper.  When I traceroute to that nameserver,
> it never reaches it from our network.  My network gurus decided to test
> some things with routing and shut off one of our core routers.  Traces
> would sometimes work.  When the trace reached past a certain cox router
> ( the dig was successful.  The very next time the trace would
> stop at this router and the dig would fail.  Again, this is only true on
> the aix boxes.  What in the world is going on here????  There is a mixture
> of problems.  Now that both our core routers are back up I never get a
> successful trace to that server, but this does not affect any other os.
> What does aix do differently????

> Please. Anyone.  Got any advice?

My guess is that AIX home-made MSS-probe gets problem. Try reducing MSS
and try again.

Peter Håkanson         
        IPSec  Sverige      ( At Gothenburg Riverside )
           Sorry about my e-mail address, but i'm trying to keep spam out,
	   remove "icke-reklam" if you feel for mailing me. Thanx.

More information about the bind-users mailing list