BIND 9.2.2 recursive queries lag badly, Bind8 does not

bind-list at bind-list at
Fri Nov 12 18:01:13 UTC 2004

Hello List --

I tried searching for this in the archives and didn't see anything

We are an ISP with caching resolvers running BIND9.2.2 on Solaris 8 that
are not behind firewalls.  Upon running scripts to test unrelated issues,
I noticed that any time I queried any of my resolvers for domains that
have not been cached, the recursive query response times are horrible --
consistently over 4 seconds.  If I clear the cache and run a script that
digs over 100 random domains, all of them come back > 4 seconds.  Nothing
has changed on our resolvers' config in months.  Root hint file is up to
date.  Dig +trace or debug isn't showing anything. Tcpdump/snoop shows
nothing, other than an empty hole when the machine is waiting for a
response back from any root server.  Queries against the boxes locally vs.
queries from another machine make no difference.  We have tried boxes that
have not been patched in months as well as up-to date machines.  All the

Here's the options we have:

options {

        directory "/var/named";
        max-ncache-ttl 10800;
        transfers-in 25;
        notify no;
        allow-query { CSR; DEV; localhost; };
        recursion yes;
        recursive-clients 100000;
        allow-transfer { none; };
        interface-interval 0;
        cleaning-interval 30;
        blackhole {;; };
        pid-file "";


Although I would be happy to post more info for your review, my questions
are these:  Has anyone else noticed this lag in recursion recently?  Can
anyone on this list try clearing their cache and then running queries for
random domains and noting the response time?

Curiously, an old BIND8 box we have does NOT experience this lag, no
matter what.

Any insight you may have is appreciated.


-Erik J

More information about the bind-users mailing list