Lookup weirdness

Mike B toastyhamster at hotmail.com
Fri Nov 19 18:41:55 UTC 2004

Ok, this has me baffled.

I'm running a primary/secondary DNS server, neither are able to resolve
anything in the 152.158 domain (the example I am using is Everywhere else on the 'Net I have tried can. The only
anomaly I can find is that www.dnsstuff.com occasionally shows a bad
delegation, this is a fault of one of the ARIN servers, which is
delegating it to a now decommissioned ibm.net server. However, my
queries on this subnet never leave the local DNS server (proven by
tcpdump and firewall logs). Forward lookups for ns.uk.prserv.net work
intermittently, as do queries on all the AT&T DNS servers in that

I have tried to restart BIND, with no luck. This started earlier this
week after a faulty BGP route led the path to 152.158. through a broken
ISP router interface, however this has no been fixed. on config changes
have been made recently.

I can telnet to on port 53. I can even use the server
command in nslookup to query it (after the initial lookup has timed
out). I have turned on full logging and can see the query hitting the
logs. I have dumped the cache and compared against a working machine I
can see the reverse lookup cache is missing for that subnet. I have used
nslookup -d2 and dog +trace, neither leave the local machine, even after
immediately starting BIND. I have replicated the config on another DNS
pair outside of the subnet and it works perfectly. With tcp 53 and udp
53 access proven though I don't know why BIND will not at least query
the root name servers for the answer. There are no entries for 152.x in
named.conf. BIND version is 9.2.1.

Tearing my hair out!

ARIN failure here for completeness (you need to run it a few times to
get it to fail, depending on which arin.net server you end up at):

How I am searching:
Asking c.root-servers.net for PTR record:
       c.root-servers.net says to go to figwort.arin.net. (zone: 152.in-
Asking figwort.arin.net. for PTR record:
       figwort.arin.net [] says to go to ns01.ca.us.ibm.net.
(zone: 158.152.in-addr.arpa.)
Asking ns01.ca.us.ibm.net. for PTR record:
Error: Couldn't resolve DNS server name/IP [ns01.ca.us.ibm.net][11004]



More information about the bind-users mailing list