More on named-checkconf error message

Ian Wark ianshoko at
Tue Oct 19 14:31:35 UTC 2004

Thank you very much for your prompt response.

I was running the named-checkconf from a user with administrator privileges, 
but none on the dns folder. After changing user permissions, however, I 
still get the same fatal error. But here is more information. It is not that 
I cannot run the exe file, because if I use the -v option I get output 
indicating the version (I presume that is what the -v option does). The 
programs runs normally. Unfortunately, I cannot get anything else to work. 
In addition, I can get rndc.exe and named-checkzone to throw the same fatal 
exception too. But it doesn't happen all the time. I have received different 
messages from both checkzone and rndc too. I can get loading "zone" from 
"" class "IN" for the former on the file. And permission denied for rndc.

Exception Information
Code: 0xc0000005 Flags: 0x00000000
Record: 0x0000000000000000 Address: 0x000000007c958fea

ntdll.dll comes up each time as the main cause in the windows error dialog. 
It is the one that asks if I want to send the error info to Microsoft.

In Visual C++ debugger the message is
Unhandled exception in [XXXX.exe] (NTDLL.DLL): 0xC0000005: Access Violation

I get the feeling this does not have anything to do with permissions after 
all. Just accessing an address that doesn't exist? Is it possible that XP 
service pack 2 is the problem? I just downloaded it recently.

Anyway, following up your other response. I take it that "Almost nothing 
needs to be there" means that the directory directive in named.conf and the file are all that I need. Correct? The 
documentation seems to say that if I run rndc-confgen -a then I do not need 
to add anything to named.conf, because rndc.key file is created.

Ian Wark

More information about the bind-users mailing list