multiple named process in a single machine?

Mickey.Olsberg at Mickey.Olsberg at
Fri Jan 28 06:38:40 UTC 2005

Your problem is not with port 53. Note that it states it is having 
trouble binding a TCP socket, so even if it was port 53 your query would 
have worked on UDP port 53. Zone transfers would not have though...

Anyway, port 953 is bound to loopback and that is why you are getting 
the address in use message. The named process listens on this port for 
rndc (remote ndc) commands. You will either need to change the IP in the 
controls section of each named.conf (which means using rndc as a true 
remote control mechanism) or by changing the port for one of the servers 
(which means modifying the port that the rndc commands uses every time 
you want to manage that server). My recommendation is that you use the 
first... Hope this helps!

Mickey Olsberg

-----Original Message-----
From: yakut [mailto:yakut at]
Sent: Thursday, January 27, 2005 6:58 PM
To: bind-users
Subject: multiple named process in a single machine?


Since named seems do not scale well on 4+ CPUs, I plan to use multi 
named process in a single machine with multi IPs. 

I managed started named process with different named.conf files, and 
limit IP address for each with 'listen-on' option in named.conf. 

But from syslog, a message said:
listening on IPv4 interface eth0,
binding TCP socket: address in use
couldn't add command channel address in use
couldn't add command channel ::1#953: address in use
zone xxx/IN: loaded serial 42

I tried dig from clients to different server IPs, it just work! 

Anybody can tell me does this make sense? If yes how to eliminate 
the 'addr in use' errors in syslog? 


More information about the bind-users mailing list