couldn't add command channel ::1#953: address not available

MJ php at
Mon Mar 14 10:59:38 UTC 2005

Actaully the only packaged BIND version available on is
9.2.3, anyways I will try to compile the latest version. One question, I
have seen named.conf of a running name server "without any control
statement" and the admin of that server is using rndc, how it is
possible? As I tried this thing and come up with the error.

Many thanks,

-----Original Message-----
From: Jim Reid [mailto:jim at] 
Sent: Monday, March 14, 2005 1:50 PM
To: MJ
Cc: bind-users at
Subject: Re: couldn't add command channel ::1#953: address not available

>>>>> "MJ" == MJ  <php at> writes:

    MJ> Hi, I have installed BIND 9.2.3 from on
    MJ> solaris 8.

Please run up to date software. If you run old code, you could be
running into bugs and problems that have already been fixed in the
latest version. This appears to be what's happened to you here. The
current release is BIND9 is 9.3.1. If you must run 9.2, the current
version is 9.2.5.

    MJ> As per the ARM, I run "rndc-confgen -a" to generate
    MJ> /etc/rndc.key and as per the manual it is not required to
    MJ> insert any thing in /etc/named.conf if you are using
    MJ> rndc-confgen with -a. But now I am getting the following error

    MJ> Mar 14 10:10:03 sune named[501]: [ID 873579 daemon.notice]
couldn't add command channel ::1#953: address not available

::1 is the IPv6 loopback address. You've somehow told the name server
to listen on this for command channel messages and IPv6 isn't
available in your OS. Or not configured)  Fix the controls{} statement
in named.conf to explicitly reference the IP address(es) you want the
server to listen on for control messages. ie:

controls {
        inet allow {; } keys { localkey; };

BTW, the FAQ has something to say about this:

   Old versions of rndc-confgen used localhost rather than
   in /etc/rndc.conf for the default server.  Update /etc/rndc.conf
   if necessary so that the default server listed in /etc/rndc.conf
   matches the addresses used in named.conf.  "localhost" has two
   address ( and ::1).

Note too that rndc-confgen is a crutch for the clueless. It's no
substitute for taking the time to think about how nameserver control
should be done and configfuring rndc.conf and the controls{} statement

More information about the bind-users mailing list