Has this bug been fixed since BIND 9.3.0?

Dave Clark bind-users at dollardns.net
Wed Nov 16 15:28:25 UTC 2005

It seems that switching from allow-policy to allow-update is not done
cleanly when you `rndc reconfig`.  I had a zone that used allow-policy to
authenticate updates.  For testing, I removed the key from the config and
changed the zone to an IP based allow-update and executed `rndc reconfig`.
However, when doing updates on the zone using nsupdate, I get a refused
response when attempting delete or add updates.  Sending queries with only
prerequisites returned NXRRSET as expected.  So then I restarted the server
and was able to do delete and add updates just fine.  I tried starting out
with TSIG based allow-update and switching that to IP based allow-update and
did a `rndc reconfig` and that worked intuitively.

Has this been fixed in BIND 9.3.1 or the BIND 9.3.2 beta?

Do you need more details to reproduce the problem?


----- Original Message ----- 
From: "Noc Phibee" <noc at phibee.net>
To: <>
Sent: Wednesday, November 16, 2005 3:28 AM
Subject: Use bind with SSL ?

> Hi
> i have installed Bind 9.X on Mandriva Linux, no problems, that work's
> it's good.
> Now i want add 2 servers for secondary name server and i have two
> questions :
> 1- The Zone transfert Master to Slave can use SSL for crypt the transfert
> 2- Can i said to slave server of automatiquely add a new zone when the
> master
> notifiy a new domains ?.
> Actually, the master sent the notify and if i don't have add manually
> into the /etc/named.conf
> of the secondary, he reject it.
> Thanks for your help.

More information about the bind-users mailing list