Bind 9.2.2 configure doesn't honor LDFLAGS variable?

Yaroslav Tarasenko tswiah at
Fri Apr 7 09:04:31 UTC 2006


I've tried to compile the GeoIP patch for Bind 
( following instructions from INSTALL 
file in the patch distribution.
This patch is for Bind version 9.2.4, but for some reasons i'd like to 
use Bind 9.2.2, so i patched 9.2.2 sourcecode. I ran configure script:
CFLAGS="-I/usr/local/geoip/include" LDFLAGS="-L/usr/local/geoip/lib 
-lGeoIP" ./configure --prefix=/usr/local/bind
(Maxmind's GeoIP C interface are already installed under /usr/local/geoip).

Running 'make' gives me such an error
gcc -I/usr/local/geoip/include -o named aclconf.o client.o config.o 
control.o controlconf.o interfacemgr.o listenlist.o log.o logconf.o 
main.o notify.o query.o server.o sortlist.o tkeyconf.o tsigconf.o 
update.o xfrout.o zoneconf.o lwaddr.o lwresd.o lwdclient.o lwderror.o 
lwdgabn.o lwdgnba.o lwdgrbn.o lwdnoop.o lwsearch.o  unix/os.o 
../../lib/lwres/liblwres.a ../../lib/dns/libdns.a   
../../lib/isccfg/libisccfg.a ../../lib/isccc/libisccc.a 
../../lib/isc/libisc.a  -lnsl
../../lib/dns/libdns.a(acl.o): In function `dns_aclelement_match':
acl.c:(.text+0x4c6): undefined reference to `GeoIP_new'
acl.c:(.text+0x4fc): undefined reference to `GeoIP_country_code_by_addr'
collect2: ld returned 1 exit status
make[2]: *** [named] Error 1
make[2]: Leaving directory `/home/yaroslav/build/BIND/bind-9.2.2/bin/named'
make[1]: *** [subdirs] Error 1
make[1]: Leaving directory `/home/yaroslav/build/BIND/bind-9.2.2/bin'
make: *** [subdirs] Error 1

Seems like make process doesn't honors LDFLAGS environment variable.
The same actions for 9.2.4 give completely normal build process.
Can you please give me an advice on how to cope with this situation?

Thanks in advance.

  Yaroslav Tarasenko aka Taras Tswiah
  UNIX systems administrator

More information about the bind-users mailing list