BIND 9 Memory Leak?

Greg Burch greg.burch at
Tue Jan 23 14:36:56 UTC 2007

We're running multiple name BIND servers (on Red Hat EL AS4) in our
organization (some at version 9.3.1, others have been upgraded to
9.3.2-P2), and in the last month or two, we've been running into issues
where DNS resolution on some of our servers slows to a crawl, because
the memory begins swapping to disk.  We've tried various things, such
as tweaking the max-cache-size and cleaning-interval parameters, with
no luck.  There had been no recent upgrades to BIND before these
problems began occurring, although other packages on the system may
have been updated via a Red Hat satellite server.

As an example of the "memory leak", here's top output that shows BIND
using over 300M of memory:

18246 named     19   0  391m 334m 1204 S   17 33.1   1462:47 named

When I run an "rndc dumpdb", we can see the cache is 5.8M:

-rw-r--r--  1 named named 5812840 Jan  5 14:31 named_dump.db

The data itself that the server is master for is 1.9M.

So the question is why is named using up so much memory?  I've seen
other posts to this list discussing what sounds like this same issue,
but the only responses I've seen have assumed that it was the cache
taking up all of memory, and suggested tweaking the max-cache-size
parameter.  I've noticed in the BIND 9.4.0rc1 release notes a line that
reads, "Addition memory leakage checks"; does this mean there are known
memory leak issues that are being investigated?

Currently, we're forced to restart the process nightly via cron to
avoid memory swapping issues...any other ideas on a potential solution
would be appreciated.

Greg Burch

More information about the bind-users mailing list