BIND 9 Memory Leak?

Stephen John Smoogen smooge at
Tue Jan 23 21:57:31 UTC 2007

On 23 Jan 2007 06:36:56 -0800, Greg Burch <greg.burch at> wrote:
> We're running multiple name BIND servers (on Red Hat EL AS4) in our
> organization (some at version 9.3.1, others have been upgraded to
> 9.3.2-P2), and in the last month or two, we've been running into issues
> where DNS resolution on some of our servers slows to a crawl, because
> the memory begins swapping to disk.  We've tried various things, such
> as tweaking the max-cache-size and cleaning-interval parameters, with
> no luck.  There had been no recent upgrades to BIND before these
> problems began occurring, although other packages on the system may
> have been updated via a Red Hat satellite server.

Are the servers acting as both caching/resolving name servers for
other machines and as an authoritative name server for your zone? How
many clients are getting the data?

The other issue might be with compile options and choices when you
compiled your version of BIND. The RHEL-4 Bind is 9.2.4, so I am
guessing there was a recompile somewhere.

> As an example of the "memory leak", here's top output that shows BIND
> using over 300M of memory:
> 18246 named     19   0  391m 334m 1204 S   17 33.1   1462:47 named
> When I run an "rndc dumpdb", we can see the cache is 5.8M:
> -rw-r--r--  1 named named 5812840 Jan  5 14:31 named_dump.db

The file on my part is an ASCII dump so look for data that doesnt
match your server.

> The data itself that the server is master for is 1.9M.

Stephen J Smoogen. -- CSIRT/Linux System Administrator
How far that little candle throws his beams! So shines a good deed
in a naughty world. = Shakespeare. "The Merchant of Venice"

More information about the bind-users mailing list