installing on SLES 10sp3

David Forrest drf at
Thu Sep 9 20:21:25 UTC 2010

On Thu, 9 Sep 2010, Lyle Giese wrote:

> David Forrest wrote:
>> On Thu, 9 Sep 2010, Lyle Giese wrote:
>>> I am trying to install bind 9.7.1-P2 from source on a SLES 10 SP3 server.
>>> When I run named from the command line, it runs, but fails to open and 
>>> write any of the zone files it downloaded.
>>> named -c /etc/named.conf   (yes I am running this a root)


> I checked the version of named and named-checkconf using -v and -V and tried 
> running it via the full path.  They have the right version number 9.7.1-P2.
> Lyle Giese

Lyle,  since it runs from the command line, it would seem that you're left 
with the zone files and those special files named needs.  From the 
named-checkconf man:
  "Note: files that named reads in separate parser contexts, such as 
rndc.key and bind.keys, are not automatically read by named-checkconf.
    Configuration errors in these files may cause named to fail to run, 
even if named-checkconf was successful.  named-checkconf can be run on 
these files explicitly, however."

I have also found some pesky errors in my zone files by running 
named-checkzone on them. That may be indicated as you can run but the 
zones don't open.


David Forrest                     e-mail   drf at
Maple Park Development Corporation
St. Louis, Missouri    (Sent by ALPINE 2.01 FEDORA 11 LINUX)

More information about the bind-users mailing list