installing on SLES 10sp3

Lyle Giese lyle at
Thu Sep 9 18:04:17 UTC 2010

David Forrest wrote:
> On Thu, 9 Sep 2010, Lyle Giese wrote:
>> I am trying to install bind 9.7.1-P2 from source on a SLES 10 SP3 
>> server.
>> When I run named from the command line, it runs, but fails to open 
>> and write any of the zone files it downloaded.
>> named -c /etc/named.conf   (yes I am running this a root)
> I had similar problems with 9.7.1-P2 and it seemed that the named init 
> script generated for F11 reset permissions on the /var/named 
> directory. Go figure.  But, to make it work, I inserted a chmod 
> command just before it launched the daemon to set /var/named as owned 
> by named. I also like the executable in /usr/local/sbin rather than 
> /usr/sbin as the script said. so mine now is as below:
> ...
>  chown -hR named:named /var/named                      ## DRF
> #    daemon /usr/sbin/"$named" -u named ${OPTIONS};    ## DRF
>  daemon /usr/local/sbin/"$named" -u named ${OPTIONS};  ## DRF
> ...
> I don't start it directly from the command line though, so running 
> from the command line as root should not have that ownership problem.  
> You might check the actual install directory as you might be running 
> the old executable.
> Dave

I checked the version of named and named-checkconf using -v and -V and 
tried running it via the full path.  They have the right version number 

Lyle Giese
LCR Computer Services, Inc.

More information about the bind-users mailing list