Bind does not reply with "no such name" to A query

Gaurav Kansal gaurav.kansal at
Wed Nov 9 11:18:48 UTC 2011

Dear Sven,


Client queries a name for Both A and AAAA records.

Now, the thing is NAME exist but either A or AAAA doesn't exist for this.
Then how can a server reply that "no such name"??????



Thanks and Regards,

Gaurav Kansal




From: at
[ at] On Behalf Of
Beisiegel, Sven
Sent: Wednesday, 09 November, 2011 3:04 PM
To: bind-users at
Subject: Bind does not reply with "no such name" to A query


Hi everyone,
I tried to find a solution to this using Google, but I failed. I'm wondering
if this is expected behavior of bind9 or if this is configurable.

I have a domain configured and my server is the authoritative name server
for this domain.
My server is reachable via IPv4 and IPv6 address.
2 records are configured like this:


dls-koe.gvs.local.                 2h     A

dls-koe-v6.gvs.local.              2h     AAAA   2001:4dd0:f9c0:100::251


I have clients that are running with IPv4 and IPv6 address at the same time
and are configured with one of the FQDNs above. When the client is sending a
query for one of the names, it directly sends an A and AAAA query.
Now for example: The client sends an A query for "dls-koe-v6.gvs.local",
which is only configured as AAAA record in the server. I now would expect
the server to reply with "no such name", but it doesn't.
Other example: The client sends an AAAA query for "dls-koe.gvs.local", which
is only configured as A record in the server. Same result.

My question is: Why is bind not replying with "no such name" in this case?
Is this expected behavior? Maybe a configuration issue?

Thanks in advance for any help,


More information about the bind-users mailing list