Linux issue with make test failures, 9.9.2-P1

Jeff Earickson jaearick at
Thu Dec 6 15:58:05 UTC 2012


Yup, I knew all of that and that is what I have always done.  This morning
I got things to work by skipping the -j option of gmake to do parallel compiles,
and the tests then worked.

Before I always did:

gmake -j2 up (as root)
gmake test

Once I didn't do the parallel compile (-j2), the tests worked.  But I did not
see any failures from a parallel compile either.  Weird.

Jeff Earickson
Colby College

On Thu, Dec 6, 2012 at 10:40 AM, Evan Hunt <each at> wrote:
> Jeff Earickson <jaearick at> wrote:
>> The "make test" stuff is failing miserably for me on Linux (Redhat
>> 6.3, x64) with 9.9.2-P1:
> I'm pretty sure you haven't set up the local addresses the test servers
> need to run on.  From the top of the bind9 tree, run the command:
>         $ sudo sh bin/tests/system/ up
> ...then run "make test" and you'll probably get better results.
> The command sets up loopback addresses through
>  The system tests run servers on those addresses and make
> them talk to each other.  Without addresses configured, about 90% of
> the tests will fail.
> --
> Evan Hunt -- each at
> Internet Systems Consortium, Inc.

More information about the bind-users mailing list