rndc reconfig does not work

benjamin fernandis benjo11111 at gmail.com
Fri Dec 28 13:06:56 UTC 2012


As per my understanding, if we change anything in named.conf and then
if we require to enable changes without service restart, we go with
rndc reconfig.

So i tried it but it does not work.

first i use recursive dns service with direct root server contact and
then i add forwarder ip and then i run rndc reconfig command but still
no effect and then i run service named restart and it comes into

key "rndckey" {
algorithm hmac-md5;
secret "...";
controls {
inet allow {; } keys { "rndckey"; };
options {
	listen-on port 53 { localhost; };
	listen-on-v6 port 53 { ::1; };
	directory 	"/var/named";
	dump-file 	"/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
	forwarders {; };
        allow-query-cache {; };
        recursion yes;

	/* Path to ISC DLV key */
	bindkeys-file "/etc/named.iscdlv.key";

	managed-keys-directory "/var/named/dynamic";

logging {

    channel default_syslog {
        // Send most of the named messages to syslog.
        syslog local2;
        severity debug;
zone "." IN {
	type hint;
	file "named.ca";

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";
include "/etc/rndc.key";

Is there any problem with my config ?


More information about the bind-users mailing list