Stalling slave transfers

Luther, Dan Dan.Luther at
Thu May 9 12:19:17 UTC 2013


What happens when you "dig +tcp @"? Specifically I'm wondering here if the slave you're having problems with is blocking TCP port 53. Such a configuration would allow you to query the master server, but not transfer to/from it.

Dan Luther
Operations Engineer
Systems Operation Engineering 
Level 3 Communications
One Technology Center, Tulsa OK 74103
e: dan.luther at

-----Original Message-----
From: at [ at] On Behalf Of Tom Sommer
Sent: Wednesday, May 08, 2013 1:16 PM
To: Cathy Almond
Cc: bind-users at
Subject: Re: Stalling slave transfers

On 5/8/13 12:25 PM, Cathy Almond wrote:
> On 08/05/13 08:26, Tom Sommer wrote:
>> Hi,
>> I have a problem with one of 3 slave servers, all set up the exact 
>> same way, with the exact same bind version and configuration.
>> One slave has a problem transfering zones from the master.
>> The logfiles are flooded with "received notify for zone" .. "refresh 
>> in progress, refresh check queued" lines and "rndc status" returns a 
>> constant high number of "soa queries in progress".
>> After a few hours the zones are transfers, so the connection to the 
>> master is working, but there is a major delay. I tried resetting the 
>> slave and transfering ALL slave zones again, which worked fine 
>> instantly. The problem still appeared again after a few hours though.
>> The master has three network-paths, one on external IP, one on 
>> internal IP and one on IPv6. All 3 paths work fine, because the 
>> transfers happen after an hour or so.
>> There is no hints in the master's log.
>> The other two slaves are running perfectly, no errors or delays what 
>> so ever.
>> Bind version 9.9.2-P2 (recently upgraded to).
>> Any hints would be appreciated, as I feel like I've exhausted most options.
>> Thank you.
> Have a look at this KB article (you'll need to register to view - but 
> registration is open to all):
> effectively-for-zone-transfers-particularly-with-many-frequently-updat
> ed-zones.html
> Also - and this isn't covered in that article (yet) - if you're using 
> views, then use-alt-transfer-source defaults to 'yes'.  You might want 
> to set it explicitly to 'no' or to define alt-transfer-source and/or 
> alt-transfer-source-v6.
Thank you, great resource. I think I solved it with raising serial-query-limit, it's just odd that it's not required on the other two servers.

Another issue has arisen now though, the logfile is filled with lots of
named[5596]: zone refresh: failure trying master (source operation canceled

But if I do a "dig @" it's working just fine. Same server as with the previous issue.

Any thoughts? Thank you.

// Tom
Please visit to unsubscribe from this list

bind-users mailing list
bind-users at

More information about the bind-users mailing list