Unable to build BIND 9.11.0-P3 on RHEL 6.0 64-bit

greg.rabil at bt.com greg.rabil at bt.com
Tue Mar 28 22:05:22 UTC 2017

Hi folks,
I am having trouble getting BIND 9.11.0-P3 to build on RHEL 6.0 64-bit.  I am linking it with static OpenSSL (1.0.2j) and GeoIP (1.6.6) libraries.  Here are my configure options:

--enable-shared=no   (I have also tried --disable-shared)
--with-openssl=/opt/ssl    (this is where OpenSSL was configured with --prefix, and installed)
--with-geoip=/opt/geoip    (this is where GeoIP was configured with --prefix, and installed)

Here is the configuration summary:
Configuration summary:
Optional features enabled:
    Multiprocessing support (--enable-threads)
        Mutex lock type: adaptive
    GeoIP access control (--with-geoip)
        Algorithm: aes
    IPv6 support (--enable-ipv6)
    OpenSSL cryptography/DNSSEC (--with-openssl)
    XML statistics (--with-libxml2)
    HTTP zlib compression (--with-zlib)
    GOST algorithm support (encoding: raw) (--with-gost)
    ECDSA algorithm support (--with-ecdsa)
    Allow 'fixed' rrset-order (--enable-fixed-rrset)
    AAAA filtering (--enable-filter-aaaa)
    Print backtrace on crash (--enable-backtrace)
    Use symbol table for backtrace, named only (--enable-symtable)
    Dynamically loadable zone (DLZ) drivers:

Features disabled or unavailable on this platform:
    Large-system tuning (--with-tuning)
    Allow 'dnstap' packet logging (--enable-dnstap)
    GSS-API (--with-gssapi)
    PKCS#11/Cryptoki support (--with-pkcs11)
    Native PKCS#11/Cryptoki support (--enable-native-pkcs11)
    Use libseccomp system call filtering (--enable-seccomp)
    Very verbose query trace logging (--enable-querytrace)
    Use GNU libtool (--with-libtool)
    Automated Testing Framework (--with-atf)
    Python tools (--with-python)
    JSON statistics (--with-libjson)
    LMDB database to store configuration for 'addzone' zones (--with-lmdb)

Make fails with this error, which seems to indicate that it is still trying to build a shared-library, even though I have explicitly disabled that feature.  Again, I've tried both --disable-shared and --enable-shared=no.

gcc -shared -o sample.so db.o driver.o instance.o lock.o log.o syncptr.o zone.o \

               ../../../../../lib/dns/libdns.a ../../../../../lib/isc/libisc.a  -L/opt/ssl/lib -lcrypto -ldl ../../../../../lib/dns/libdns.a ../../../../../lib/isc/libisc.a -ldl -lrt -lpthread -lm -lGeoIP  -L/opt/geoip/lib -lxml2 -lz -lm

/usr/bin/ld: /opt/ssl/lib/libcrypto.a(cryptlib.o): relocation R_X86_64_32 against `OPENSSL_ia32cap_P' can not be used when making a shared object; recompile with -fPIC

/opt/ssl/lib/libcrypto.a: could not read symbols: Bad value

collect2: ld returned 1 exit status

make[5]: *** [sample.so] Error 1

Any help is appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/bind-users/attachments/20170328/c7ae832a/attachment.html>

More information about the bind-users mailing list