Weird issue with bind & router

Mark Andrews marka at
Thu May 25 22:01:45 UTC 2017

Even home routers sometimes try to police DNS traffic and I would
expect there is a bug in the code doing that.

As this is a ISP supplied router (if my Google Foo is accurate)
report the fault to the ISP.  It is their job to fix it.

If it wasn't a ISP supplied router, update the router firmware and
see if the problem goes away.  If that doesn't work.  Try to report
the bug to the router manufacture.  If you can't do that return the
router requesting a full refund as it is not fit for purpose.

Suppliers and manufactures need to get some pushback on broken products.


in message <8c799e52-3a3d-46b9-9f31-8df4e3b1d204 at>, "john w. blue" writes:
> chris,
> first, what a strange problem to have.
> you really need to spend some time capturing the traffic placed on the wire=
>  via tcpdump and then slicing it up for clues with wireshark.
> if you set a continuous ping to the router that would be a good timestamp t=
> hat you can use to correlate as a marker.  when it stops responding look at=
>  all of the other traffic around that time.
> i doubt that it will be bind but stranger things have happened before!
> good luck.
> john
> sent from nine<>
> from: chris serella <serella_c at>
> sent: may 25, 2017 9:24 am
> to: bind-users at
> subject: weird issue with bind & router
> i run a small dev system on my home network, housing dns etc all under the =
> one server.
> system: ubuntu16.04 server, ispconfig etc etc etc, you get the idea.
> anyway, the problem i am having comes down to the router rebooting (is it c=
> rashing? i cant tell) every time bind starts/restarts. this ordinarily woul=
> dnt be an issue, dns rarely changes so the service does not need restarting=
>  but the problem occurs on system boot too.
> the router in question is a plusnet hub one which i believe is actually a r=
> epackaged bt hub 5. the "server" is an acer ax3300 desktop with ubuntu serv=
> er installed.
> troubleshooting was difficult as i couldnt isolate what it was until i went=
>  over to ispconfig for assistance, they informed me that a dns reload on th=
> eir software simply saves data to files and initiates a service restart.
> with this information to hand i made no changes to the dns in ispconfig, in=
> stead i opened a terminal and tunnels into the server and issued a bind9 re=
> start from there.
> sure enough the problem reared its ugly little head, the ssh session droppe=
> d out and looking over to the router i could see it was going through its p=
> ower cycle. to be sure this wasn't some freakishly well timed coincidence, =
> i completed the steps several times more (3) all with the same result.

Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: marka at

More information about the bind-users mailing list