BIND and UDP tuning

Alex mysqlstudent at
Fri Sep 28 13:06:17 UTC 2018


> Hi Alex,
> Have you tried on a separate physical server? To rule out the actual hardware as being the problem?
> Is this some  user grade PC with either onboard or external ethernet interface, or a proper server grade equipment? Age of equipment? What else does that machine do?

This is a Xeon 8-core E31240 3.30GHz with 16GB. It's a few years old.
I've also recently tried with an i7 8700 with 32GB running the same
version of fedora28 with the same bind and had the same problem. I've
also mentioned previously that I've tried unbound and had the same
postfix "Name service error" error.

I believe this error is not a recent thing - it goes back in the logs
for as long as I can see, meaning into previous versions of postfix
and fedora and bind. I've only now started to notice it and the impact
that I'd imagine it's having on our ability to effectively using RBLs
and process mail.

This server does only mail/spam filtering with
postfix/amavis/spassassin using bind. It's configured as a recursive
caching server and not otherwise authoritative for any of our domains.

I've recently tried to configure it with "edns no;" and/or
"edns-udp-size 512;" and it's had no effect.

Thanks so much for your help.

More information about the bind-users mailing list