BIND 9.16.15 Windows x64 broken?

Richard T.A. Neal richard at
Fri May 7 17:51:40 UTC 2021

Hi Jukka,

I spun-up a brand new Windows 2008 R2 Enterprise x64 server today to try and replicate this, and unfortunately you're right - BIND 9.16.15 won't run on that environment.

In fact if you simply try and run [dig] from the command line you will get this:

The procedure entry point GetSystemTimePreciseAsFileTime could not be located in the dynamic link library KERNEL32.dll

Having done a bit of Google'ing it appears that this method /procedure is not available in Window 7 / 2008 R2. As such it's never going to work.

I hate to be "that guy" but Windows Server 2008 R2 is of course long out-of-support from Microsoft unless you happen to have an Extended Support Agreement with them. How feasible is it for you to upgrade your Windows BIND servers to Windows Server 2012 R2 or higher?


From: bind-users <bind-users-bounces at<mailto:bind-users-bounces at>> On Behalf Of Jukka Pakkanen
Sent: 06 May 2021 11:10 pm
To: bind-users at<mailto:bind-users at>
Subject: BIND 9.16.15 Windows x64 broken?

What changed between Bind 9.16.13 and 9.16.15 Windows x64 binaries?

9.16.15 will not start at all in Server 2008 R2 Enterprise x64, 9.16.13 worked fine.

Only get "The service is not responding to the control function" when trying to start the service.

Tried this as an upgrade to the 9.16.13, or as a fresh install, same result in both cases.  Downgrading to 9.16.13 and works fine again.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bind-users mailing list