BIND 8.2.2-P5 on HP-UX 10.x

Rip Loomis Gilbert.R.Loomis at cpmx.saic.com
Mon Dec 6 21:21:45 UTC 1999


Bind-workers:

Is anyone else out there compiling 8.2.2-P5 on a
HP-UX 10.x system still?  If so, what compilers
and other utilities are you using?

After much wailing and gnashing of teeth (I'm not
an HP-UX guy), I've gotten it compiled and apparently
functional.  I've attached the diffs I had to make
to src/port/hpux10/Makefile.set.gcc--but I'm concerned
that there must have been a reason for the previous
settings.

Compile environment:
- HP-UX B.10.20 with Y2K patches and latest libc/sed
	patches
- GNU utilities installed (sorry, didn't have a
	license for the HP commercial compiler):
  . binutils 2.9.1 (including GNU "gas")
  . bison 1.28
  . flex 2.5.4a
  . gcc 2.95.2 (recompiled from source with --with-gnu-as)
  . make 3.78.1

Anyone have any suggestions?  More specifically,
does anyone have a reason why the modified Makefile.set.gcc
that worked for me shouldn't be included as the default
one?  Last thing I knew, there was only limited testing
being done at the ISC on HP-UX 10.20, since their primary
HP-UX flavor is 11.0.  (Unfortunately, a specific customer
of theirs and mine needs it on 10.20.)

Comments requested.

	--Rip Loomis


Rip Loomis		Voice Number: (410) 953-6874
--------------------------------------------------------
Security Engineer
Center for Information Security Technology
Science Applications International Corporation
http://www.cist.saic.com
  

-- Binary/unsupported file stripped by Listar --
-- Type: application/octet-stream
-- File: BIND_HP-UX_gcc2_95_2.diff




More information about the bind-workers mailing list