[bind10-dev] changing the name of the trigger command

Michal 'vorner' Vaner michal.vaner at nic.cz
Thu Jan 13 23:16:16 UTC 2011


On Thu, Jan 13, 2011 at 02:23:14PM -0800, Jerry Scharf wrote:
> Michal brought up a thought that trigger was not the best choice of 
> command for causing things to happen on the server. It's a little clumsy 
> but since the idea is to cause an event to happen on the server (freeze 
> a zone, dump the server cache, ...) we could call it "eventsend" which 
> shortens well and is pretty explicit about what is happening.

You still think about some events, but I think what you want to do are actions.
Having the user thinking there's some kind of event mechanism in the server is
IMO wrong, if there isn't.

So, how about just „do“? „runtime do freeze“ seems intuitive and nicely short.
And it is actually an imperative to the server, which is what the command
actually is.

Would that sound OK?

Have a nice day

Q:	Why was Stonehenge abandoned?
A:	It wasn't IBM compatible.

Michal 'vorner' Vaner
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <https://lists.isc.org/pipermail/bind10-dev/attachments/20110113/6ddfcffa/attachment.bin>

More information about the bind10-dev mailing list