Wildcard hardware address syntax

Glenn Satchell Glenn.Satchell at uniq.com.au
Thu Aug 3 14:38:59 UTC 2006

Hi Dan,

In your other pool(s) you may need to add

  deny members of "vmware";

Are the 192.168.203 and 172.30.1 addresses on the same wire? If so then
that's a shared subnet and dhcpd needs to be told that.


>From: "HAWKER, Dan" <dan.hawker at astrium.eads.net>
>To: "'dhcp-users at isc.org'" <dhcp-users at isc.org>
>Subject: RE: Wildcard hardware address syntax
>Date: Thu, 3 Aug 2006 15:28:50 +0100 
>HAWKER, Dan wrote:
>>># Class to match vmware MAC addresses
>>>class "vmware" {
>>>	match if substring (hardware,1 ,5) = 00:0c:29;
>>>	}
>>Have you tried substring (hardware,1 ,3) ?
>>5 bytes is never going to match 3 bytes ! You also start at byte 1 
>>(the second byte) and byte 0 is the hardware type.
>Hi Simon,
>Thanks for the reply. No, I hadn't (although have now) as to be brutally
>honest the whole class matching stuff was a little hard for me to grasp and
>as such I kind of fudged it until something worked.
>Have just tried your suggestion and unfortunately it didn't seem to work
>either. Agree about 3 bits (makes a bit more sense now), it initially seemed
>to be further down in the config where my problem lied, however...
>I have an alternative pool of addresses that this DHCP
>box is also dishing out. These are available to all, however wanted to have
>a specific area for VMware  VM's, hence my attempts. The 2 pools seem to be
>quite happily giving out leases to their appropriate machines. My VM's are
>getting the addresses quite happily and boot as normal, they
>never get the 192.168 addresses, *providing* I add the whole MAC address to
>a host declaration. However after looking at the logs, it seems the DHCP box
>is offering the VMs a 192.168 address but they never accept it (I get
>continual discover-offer-discover-offer messages in the log), so I guess
>something is awry.
>I *presumed* that my class was working, as in my understanding, as hosts are
>global and hence are not affected directly by subnet declarations, yet my
>hosts are receiving a 172 address (of which the pool says use this range and
>"allow members vmware") that the class match was being applied. I guess this
>isn't the case.
>Time to read some more docs...
>Confused :)
>This email is for the intended addressee only.
>If you have received it in error then you must not use, retain, disseminate or 
otherwise deal with it.
>Please notify the sender by return email.
>The views of the author may not necessarily constitute the views of Astrium 
>Nothing in this email shall bind Astrium Limited in any contract or obligation.
>Astrium Limited, Registered in England and Wales No. 2449259
>Registered Office: Gunnels Wood Road, Stevenage, Hertfordshire, SG1 2AS, 

More information about the dhcp-users mailing list